Opened 12 years ago

Closed 12 years ago

#2558 closed Bug (fixed)

Make failure in r9484

Reported by: Lacrocivious Owned by: charles
Priority: Normal Milestone:
Component: libtransmission Version: 1.76+
Severity: Normal Keywords: make build fail <stdarg.h> JSON_parser.c
Cc:

Description

svn checkout trunk, r9484, clean sandbox. Fedora 11 2.6.30.9-90.fc11.i686.PAE #1 SMP Sat Oct 17 11:24:32 EDT 2009 i686 athlon i386 GNU/Linux

Make fails: http://transmission.pastebin.com/d21de6560

Per suggestion by klapaucjusz: [18:25] klapaucjusz Lacrocivious: what if you #include <stdarg.h> at the beginning of JSON_parser.c?

I added that as line to JSON_parser.c

Make maked; running r9484 now (transmission-daemon on localhost; qtr client)

Change History (5)

comment:1 Changed 12 years ago by charles

Gaaaah, it's one step forward, two steps back.

comment:2 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone None Set deleted
  • Owner set to charles
  • Status changed from new to assigned
  • Version changed from 1.76 to 1.76+

comment:3 Changed 12 years ago by charles

The odd thing about this build failure is that evutil.h already includes stdarg.h, apparently unconditionally, in evutil.h line 53.

Lacrocivious: what system are you building this on?

comment:4 Changed 12 years ago by charles

Ah, Fedora 11, nvm :)

I'll try to reproduce the issue.

comment:5 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Aha... our snapshot of evutil.h includes stdarg, but the one bundled on Fedora 11 doesn't. Looks like we've stumbled across this once before in net.c as well.

Fixed in trunk for 1.80 by r9485.

Note: See TracTickets for help on using tickets.