Opened 12 years ago

Closed 12 years ago

#2590 closed Bug (invalid)

Trac refuses to compile on arch64- removing xfsprogs solves the issue

Reported by: hbernier Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.76
Severity: Normal Keywords:
Cc:

Description

According to some chatter here: http://aur.archlinux.org/packages.php?ID=26360

Other people using arch64 have the same issue since the upgrade to 1.76. (not clear). This could be an issue with the way xfsprogs is compiled on arch64, or it could not. Reporting due to disclaimer printed while trying to build transmission.

I do not use xfs so I removed the package. This resolved the build problem for me.

configure: WARNING: xfs/xfs.h: present but cannot be compiled configure: WARNING: xfs/xfs.h: check for missing prerequisite headers? configure: WARNING: xfs/xfs.h: see the Autoconf documentation configure: WARNING: xfs/xfs.h: section "Present But Cannot Be Compiled" configure: WARNING: xfs/xfs.h: proceeding with the preprocessor's result configure: WARNING: xfs/xfs.h: in the future, the compiler will take precedence configure: WARNING: ## ------------------------------------------------------- ## configure: WARNING: ## Report this to http://trac.transmissionbt.com/newticket ## configure: WARNING: ## ------------------------------------------------------- ##

Change History (2)

comment:1 Changed 12 years ago by charles

Ticket #2606 has been marked as a duplicate of this ticket.

comment:2 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

This appears to be an XFS issue rather than a Transmission one. Reported upstream to http://oss.sgi.com/bugzilla/show_bug.cgi?id=858

Note: See TracTickets for help on using tickets.