Opened 13 years ago

Closed 12 years ago

#2596 closed Bug (invalid)

WebGUI: uploaded torrent arent append to downloads

Reported by: madmaurice Owned by: kjg
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.76
Severity: Normal Keywords: needinfo
Cc:

Description

If i upload a torrent file via the webgui ("Open">"Browse">"Upload") the torrent isn't appended to the list.

in fact, nothing happens except the upload "dialog" hides.

No errors in logs/output found. Nothing is printed when running daemon with -f. It also doesnt crash.

This bug occured on a Debian Lenny root server with Transmission 1.76 and Firefox 3.5 as browser.

Note: Not the same bug as #2703. the x-session-id is sent.

Attachments (1)

ubuntu-8.04.3-alternate-i386.iso.torrent (27.6 KB) - added by madmaurice 13 years ago.
torrent file i tested.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by KyleK

More information is needed for this.

First, raise the message log level of Transmission by editing the settings.json by hand (quit Transmission first!):

"message-level": 4,

Then try again. Also, information about the torrent itself is essential. If it's a legal torrent, attach it. Otherwise make sure that the torrent is valid (i.e. try with a different client).

comment:2 Changed 13 years ago by madmaurice

It should be valid cause it starts and downloads well via transmission-remote -a file.torrent also the same torrent works if added by url.

i set message-level to 4 in the settings.json and get many messages and one error

[15:13:44.657] Couldn't read "/usr/local/share/transmission/web/images/buttons/cancel.png": No such file or directory

which doesnt have much to do with my problem. but in the moment when i submit the upload no message is printed to the terminal.

same torrent via url shows me

[15:17:01.601] Couldn't read "/home/transmission/.config/transmission-daemon/resume/ubuntu-8.04.3-alternate-i386.iso.a976d43c7dbe414f.resume": No such file or directory
[15:17:01.601] ubuntu-8.04.3-alternate-i386.iso: Couldn't read "/home/transmission/.config/transmission-daemon/resume/ubuntu-8.04.3-alternate-i386.iso.a976d43c7dbe414f.resume"; trying old format.
[15:17:01.601] Couldn't read "/home/transmission/.config/transmission-daemon/resume/a976d43c7dbe414f98300104fd2c16d0dc3a9ab2-daemon": No such file or directory
[15:17:01.602] Couldn't read "/home/transmission/.config/transmission-daemon/resume/a976d43c7dbe414f98300104fd2c16d0dc3a9ab2": No such file or directory
[15:17:01.602] ubuntu-8.04.3-alternate-i386.iso: Couldn't read resume file
[15:17:01.616] tr_bencToFile saved "/home/transmission/.config/transmission-daemon/torrents/ubuntu-8.04.3-alternate-i386.iso.a976d43c7dbe414f.torrent"
[15:17:01.616] ubuntu-8.04.3-alternate-i386.iso: Queued for verification
[15:17:01.616] ubuntu-8.04.3-alternate-i386.iso: Verifying torrent
[15:17:01.896] ubuntu-8.04.3-alternate-i386.iso: tracker response: 200
[15:17:01.896] ubuntu-8.04.3-alternate-i386.iso: Got 18 peers from tracker

torrentfile: http://releases.ubuntu.com/hardy/ubuntu-8.04.3-alternate-i386.iso.torrent

Changed 13 years ago by madmaurice

torrent file i tested.

comment:3 Changed 12 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this bug. I went through the steps outlined, and the torrent was immediately visible.

  • Maybe you had something typed in the torrent filter which prevented it from appearing?
  • Maybe you had the "Seeding" or "Paused" filter set?
  • Can you see if the torrent made it to the daemon or not by trying to add it via the web UI as described, but then look for it by using "transmisison-remote -l"?

comment:4 Changed 12 years ago by madmaurice

  • Resolution worksforme deleted
  • Status changed from closed to reopened

It is added to the daemon and it appears in the webui when using transmission-remote -a

No im clever enough to not have set the filter in any way ( status or name )

comment:5 follow-up: Changed 12 years ago by madmaurice

Got a new error thanks to firebug

when the wbeui sends the torrent via ajax the browser returns a 409 Error.

Does this tell you anything?

comment:6 Changed 12 years ago by madmaurice

looking in google it says i should remove the #define REQUIRE_SESSION_ID

but i guess i did so.

comment:7 in reply to: ↑ 5 Changed 12 years ago by madmaurice

Replying to madmaurice:

Got a new error thanks to firebug

when the wbeui sends the torrent via ajax the browser returns a 409 Error.

Does this tell you anything?

i meant the rpc returns and the browser gets sry im german

comment:8 Changed 12 years ago by charles

  • Keywords needinfo added
  • Priority changed from High to Normal

You shouldn't need to remove #define REQUIRE_SESSION_ID in order for the web ui to work. Maybe you've got an older version of the web client in your web browser's cache?

Also, if you try to add a torrent via the web ui and then look at the torrent list via "transmission-remote -l" does that added torrent show up there but not in the web client?

comment:9 Changed 12 years ago by livings124

madmaurice: ping

comment:10 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from reopened to closed

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.

Note: See TracTickets for help on using tickets.