Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2606 closed Bug (duplicate)

Build error with transmission-svn9573 & xfs

Reported by: 1034500 Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.76+
Severity: Normal Keywords:
Cc:

Description

::Configure

./configure --prefix=/usr --disable-daemon --disable-cli --enable-gtk --enable-libnotify

::Configure Warning

checking xfs/xfs.h usability... no checking xfs/xfs.h presence... yes configure: WARNING: xfs/xfs.h: present but cannot be compiled configure: WARNING: xfs/xfs.h: check for missing prerequisite headers? configure: WARNING: xfs/xfs.h: see the Autoconf documentation configure: WARNING: xfs/xfs.h: section "Present But Cannot Be Compiled" configure: WARNING: xfs/xfs.h: proceeding with the preprocessor's result configure: WARNING: xfs/xfs.h: in the future, the compiler will take precedence configure: WARNING: ## ------------------------------------------------------- ## configure: WARNING: ## Report this to http://trac.transmissionbt.com/newticket ## configure: WARNING: ## ------------------------------------------------------- ## checking for xfs/xfs.h... yes

::Build Error

make[1]: Entering directory `/home/foo/Documents/transmission-1.76+/libtransmission' gcc -DPACKAGE_NAME=\"transmission\" -DPACKAGE_TARNAME=\"transmission\" -DPACKAGE_VERSION=\"1.76+\" -DPACKAGE_STRING=\"transmission\ 1.76+\" -DPACKAGE_BUGREPORT=\"http://trac.transmissionbt.com/newticket\" -DPACKAGE=\"transmission\" -DVERSION=\"1.76+\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DSTDC_HEADERS=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_PREAD=1 -DHAVE_PWRITE=1 -DHAVE_DAEMON=1 -DHAVE_DIRNAME=1 -DHAVE_BASENAME=1 -DHAVE_STRCASECMP=1 -DHAVE_LOCALTIME_R=1 -DHAVE_POSIX_FALLOCATE=1 -DHAVE_MEMMEM=1 -DHAVE_STRTOLD=1 -DHAVE_SYSLOG=1 -DHAVE_PTHREAD=1 -DHAVETMP_DUMMY1_ZLIB_H=1 -DHAVE_ZLIB=1 -DHAVE_LSEEK64=1 -DHAVE_DECL_POSIX_FADVISE=1 -DHAVE_POSIX_FADVISE=1 -DWITH_INOTIFY=1 -DHAVE_XFS_XFS_H=1 -DHAVE_GIO=1 -DHAVE_LIBNOTIFY=1 -DHAVE_LIBCANBERRA=1 -DHAVE_DBUS_GLIB=1 -DHAVE_LIBINTL_H=1 -DGETTEXT_PACKAGE=\"transmission\" -DHAVE_LOCALE_H=1 -DHAVE_LC_MESSAGES=1 -DHAVE_BIND_TEXTDOMAIN_CODESET=1 -DHAVE_GETTEXT=1 -DHAVE_DCGETTEXT=1 -DENABLE_NLS=1 -I. -I. -I.. -I../third-party/ -DTRANSMISSION -DPACKAGE_DATA_DIR=\""/usr/share"\" -I../third-party/dht -I../third-party/libevent -I../third-party/libevent -pthread -g -O2 -g -O0 -std=gnu99 -ggdb3 -Wall -W -Wpointer-arith -Wformat-security -Wcast-align -Wundef -Wcast-align -Wstrict-prototypes -Wmissing-declarations -Wmissing-format-attribute -Wredundant-decls -Wnested-externs -Wunused-parameter -Wwrite-strings -Wextra -Wdeclaration-after-statement -Winit-self -MT fdlimit.o -MD -MP -MF .deps/fdlimit.Tpo -c -o fdlimit.o fdlimit.c In file included from /usr/include/xfs/platform_defs.h:67,

from /usr/include/xfs/xfs.h:36, from fdlimit.c:47:

/usr/include/xfs/linux.h:101: error: expected declaration specifiers or ‘...’ before ‘off64_t’ /usr/include/xfs/linux.h:101: error: expected declaration specifiers or ‘...’ before ‘off64_t’ /usr/include/xfs/linux.h: In function ‘platform_discard_blocks’: /usr/include/xfs/linux.h:103: error: ‘start’ undeclared (first use in this function) /usr/include/xfs/linux.h:103: error: (Each undeclared identifier is reported only once /usr/include/xfs/linux.h:103: error: for each function it appears in.) /usr/include/xfs/linux.h:103: error: ‘end’ undeclared (first use in this function) make[1]: * [fdlimit.o] Error 1

2.6.32-rc8 kernel,Ubuntu 9.10,Latest Xfsprogs,etc from ftp://oss.sgi.com/projects/xfs/cmd_tars-oct_09/

Change History (4)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #2590

comment:2 Changed 12 years ago by charles

This appears to be an XFS issue rather than a Transmission one. Reported upstream to http://oss.sgi.com/bugzilla/show_bug.cgi?id=858

comment:3 Changed 12 years ago by 1034500

Thank you. Removing xfsprogs isn't much of a solution (or at all feasible) as suggested in ticket #2590.

comment:4 Changed 12 years ago by 1034500

Thanks. Using the xfsprogs-dev snapshot ( http://git.kernel.org/?p=fs/xfs/xfsprogs-dev.git;a=summary ) fixes the compiler problem.

Note: See TracTickets for help on using tickets.