Opened 11 years ago

Closed 11 years ago

#2612 closed Enhancement (fixed)

Display new transfer window when adding magnet transfer

Reported by: BigBossman Owned by: livings124
Priority: Normal Milestone: 2.00
Component: Transmission Version: 1.80
Severity: Normal Keywords:
Cc:

Description

Transmission doesn't display new transfer window when adding a magnet transfer

1.76+ (9593)

Change History (10)

comment:1 Changed 11 years ago by livings124

  • Summary changed from Transmission doesn't display new transfer window when adding magnet transfer to Display new transfer window when adding magnet transfer
  • Type changed from Bug to Enhancement

I'm going to consider this a needed enhancement more than a bug at the moment, since this is currently by design.

comment:2 Changed 11 years ago by charles

  • Version changed from 1.76+ to 1.80

comment:3 Changed 11 years ago by jch

At the time when a magnet link is added, we don't have the file list, so the transfer window would be useless.

Please don't pop windows asynchronously, since it interrupts anything else you might be doing. Some people don't spend hours staring at Transmission's UI (we spend hours staring at Transmission's debug logs instead).

comment:4 Changed 11 years ago by livings124

  • Component changed from Mac Client to Transmission

comment:5 Changed 11 years ago by charles

  • Milestone changed from None Set to 1.90

The file selections would be empty, but there are other things in the popup that might be useful, at least in the GTK+ client... (1) paused (2) download directory (3) torrent priority

comment:6 Changed 11 years ago by charles

  • Milestone changed from 1.90 to Sometime

Since we're semi-frozen for 1.90 I don't feel comfortable squeaking this in at the last minute. Punting for the next release.

comment:7 Changed 11 years ago by livings124

  • Milestone changed from Sometime to 2.00

r10465 adds this for the Mac client.

Setting to milestone 2.0. If the GTK/Qt clients aren't going to have this for 2.0, please change component to Mac client.

comment:8 Changed 11 years ago by charles

livings124: what does this look like in the Mac client?

comment:9 Changed 11 years ago by charles

Added to GTK+ client in trunk by r10644

comment:10 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

Added to Qt client in trunk by r10645

Note: See TracTickets for help on using tickets.