Opened 12 years ago

Closed 12 years ago

#2620 closed Bug (worksforme)

9611 crashes on Mac when adding multiple magnetized transfers via drag and drop

Reported by: guilherme Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.76+
Severity: Minor Keywords:
Cc: guilhermefdc@…

Description

Build 9611 running on 10.6.2, MacBook? 4,1.

Transmission crashes on Mac if more than one magnetized transfer is added via drag and drop in a small ammount of time.

Steps to reproduce: drag one magnetic link into Transmission, wait for it to appear on T's transfer list, quickly drag another one (while first one is still fetching torrent metadata - "red bar mode") -> T gets spinning ball of death, then closes [Crash logs 1 and 2]. Sometimes, it crashes even when a magnetized transfer is already downloading (i.e. not in "red bar mode" anymore), although this behavior seems to be random [Crash log 3].

I haven't been able to reproduce this by just pasting links via Cmd+U. Adding magnetized transfers by this method seems to work just fine.

Crash log 1: http://transmission.pastebin.com/m6cfe72f1 Crash log 2: http://transmission.pastebin.com/m49f329cb Crash log 3: http://transmission.pastebin.com/d6a6f6c53 (Got a couple more if needed).

Change History (4)

comment:1 Changed 12 years ago by guilherme

  • Cc guilhermefdc@… added

comment:2 Changed 12 years ago by guilherme

  • Summary changed from 9611 on Mac crashes when adding multiple magnetized transfers via drag and drop to 9611 crashes on Mac when adding multiple magnetized transfers via drag and drop
  • Version changed from 1.76 to 1.76+

comment:3 Changed 12 years ago by livings124

I can't replicate this in r9614. What are you sorting by?

comment:4 Changed 12 years ago by guilherme

  • Resolution set to worksforme
  • Status changed from new to closed

And neither can I in r9616... I was sorting by queue order; active downloads limited to 2.

Marking this as worksforme - which it does, now =). I'll test it under different settings and if something pops out, I'll reopen it.

Thanks and sorry for the mess.

Note: See TracTickets for help on using tickets.