Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2623 closed Bug (invalid)

Transmission seems to execute tracker requests for paused torrents.

Reported by: User294 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.76+
Severity: Normal Keywords:
Cc: alexandre.rossi@…

Description

Configuration:

Transmission 1.76+, using GTK version (current SVN build).
I also setted up it to pause torrents when added.

Issue:

1) Add torrent. It's expected to see torrent paused and hence no related activity should occur
2) Take a look on torrent properties - tracker information.

Result:

Looks like there is request to tracker occurs for paused torrents. At least transmission displays some peers statistic, etc. Performing any requests for paused torrents is unexpected for users (who generally expect no related activity for paused torrents)

I can see at least 2 issues. First, it can breach user's privacy since request to tracker executed for torrent even if it added as paused, without giving user a chance to override or remove tracker. Hence tracker can see that user has loaded torrent, even if user not downloads it at all and only wants to see it's properties, etc so added it as paused. Second issue is that this only causes extra load on trackers by useless requests without a good reason. I see no clue to perform any activity for paused torrents. It just wastes bandwidth and causes unnecessary load on tracker.

Expected:

No any activity for paused torrents should occur. No any requests to trackers, no any DHT activity for such torrents, etc (no new announces/peer searches). If torrent is paused, it is paused and any related activity is a bad idea.

Change History (8)

comment:1 Changed 12 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Paused transfers still scrape the trackers. This is intentional to get basic stats that a user can use in deciding to actually use the transfer.

comment:2 Changed 12 years ago by User294

As for me, if torrent paused, any related activity is unwanted. And if I would want to see if I want to download torrent, I have to start it and see how it performs. Then I may decide to remove it, etc. I'm personally consider such activity as "unwanted" and "unrequested". For me, the problem is that there is no way to view all torrent's properties to decide if I'm going to download it and retain privacy: tracker will see that I added torrent, even if I'm decided to abandon it and not going to download it at all. Also, if I would have many torrents and decide to pause some of them, this would produce quite many useless requests to trackers. If many users would do the same, trackers will be hammered by useless requests and have to spend extra traffic and processing power for virtually nothing. I'm afraid trackers may decide to ban me for excessive amount of requests at some point if I would have too many torrents added, even if they're paused. Maybe there are some better ways? Like option to add "stop torrent" mode or so? So ALL activity related to torrent will be stopped and only resumed when I'm going to actually UL/DL torrent? Me dislikes current behavior, that's why I created ticket.

comment:3 Changed 12 years ago by livings124

Trackers will not ban for scraping - the whole point of scraping is to avoid the more excessive announcing. Scraping is not a big deal; it's a small amount of bandwidth to get very basic tracker stats.

comment:4 Changed 12 years ago by User294

Well, I always thought scraping is rather intended to see "run time" stats for "running" torrents rather than for paused ones? I thought scrape idea was not to bother tracker with peer requests if we have enough peers already but still be able to have idea of "run time" stats for swarm so user still can see swarm state, etc (this can be useful for seeders, etc). Am I wrong here? I can see corner cases like "1000 torrents, 980 out of them are paused". Issuing requests for 20 torrents are perfectly ok, but for 1000 is definitely bad? And telling smth like "you should remove excessive torrents" is bad since it can be not so easy to re-add them later and generally limits usefulness of pause. Though it's up to you what to do of course, I only expressed my concerns from tester's standpoint (and this one tries to resemble user's standpoint as close as possible).

comment:5 Changed 12 years ago by livings124

Scraping is to get the basic stats for even paused torrents, so decisions can be made later. This is the intention of scraping, and as long as we follow the guidelines of scrape intervals (which we do), there shouldn't be any problems (and there haven't been).

comment:6 Changed 12 years ago by User294

Nice to read that. Then second part of my concerns is not a real issue.

comment:8 Changed 12 years ago by niol

It seems this changeset:10074 did the trick, but it was reverted in 1.92 I think, and I could not find why. The revert is in changeset:10095 .

Last edited 12 years ago by niol (previous) (diff)

comment:9 Changed 12 years ago by niol

  • Cc alexandre.rossi@… added
Note: See TracTickets for help on using tickets.