Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2627 closed Bug (duplicate)

Files Downloaded and Deselected Still Counted During "Verify Local Data" Operation

Reported by: jamesisin Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.76
Severity: Normal Keywords:
Cc:

Description

Here is the scenario:

Suppose you have a torrent which consists of 5 folders (A through E) each containing 5 files (A1, A2, A3, &c). You start the torrent and (after some amount of downloading has occurred) decide you only require certain files/folders from the torrent.

You go to the Files tab of the Preferences dialog for that torrent and deselect some of the files/folders. Let us say you deselect folders A and B and files 1, 2, and 3 from folder C (leaving 4, and 5 from C as well as D and E selected).

You then enter the torrent's folder to clean house (ie, remove the in which portions you are no longer interested). So, you delete folders A and B and files 1, 2, and 3 from C.

If you then run Verify Local Data on the torrent, Transmission will evaluate according to what it has downloaded (rather than according to what is selected in the file list). Which is to say, it will re-download any part of folders A and B and 1, 2, and 3 from C which it had previously downloaded--even though these are currently deselected in the torrent's file list.

I see two possible solutions: a) change the way Transmission evaluates the Local Data (ignoring any deselected files) or b) include a Purge Local Data feature which deletes (and registers this deletion) any local data which is outside the then current selected files parameters.

I can provide additional details as needed.

Change History (6)

comment:1 Changed 12 years ago by charles

I don't see any problem with Transmission verifying deselected files:

  • If the files are deselected but still exist, Transmission can still seed them to other users, so it makes sense to verify them.
  • If the files are deselected and have been deleted, the code still looks for the missing files, but the time it takes to do this can probably be measured in the hundredths of a second... not something that is going to bother people.

However I don't understand what you mean by "it will re-download". Verify doesn't re-download anything, does it?

comment:2 Changed 12 years ago by jamesisin

I mean precisely "it will re-download" any files which it downloaded and I deleted--even if those files are deselected in the Files tab of the Properties dialog for that torrent. Which is to say that Transmission downloads files (or file segments) which it should not download (since it has been specifically instructed not to do so).

comment:4 Changed 12 years ago by charles

My guess is that livings124 is correct.

It's possible that Transmission doesn't realize that the piece fragments have been removed until you run "Verify Local Data", at which point it tries to complete the pieces that are associated with the files you do want.

comment:5 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

Marking this ticket as a duplicate of #532

comment:6 Changed 12 years ago by jamesisin

My testing confirms this is the same issue as discussed in #532. Thank you.

I hope this matter is taken seriously. In my test the additional (unwanted) file-space was at least 697.6 MB (I won't know until the selected file has finished whether another 700 MB of drive space will be used at the other end of this file--and this is on a torrent whose pieces come in at 4.0 MB each).

Note: See TracTickets for help on using tickets.