Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2644 closed Enhancement (wontfix)

Make files-view sortable

Reported by: haravikk Owned by:
Priority: Lowest Milestone: None Set
Component: Mac Client Version: 1.76+
Severity: Trivial Keywords: feature-disparity
Cc: fortinmike@…

Description

Dead simple feature (I hope). Currently in the files tab of the inspector, it does not appear to be possible to sort the files by name, rank, or any other useful attribute. It would be nice if the column headings were click-able to allow sorting.

As a side-note, one attribute I'm most interested in for sorting is the progress of individual files, but this currently doesn't have its own column, but could possibly be the behaviour of the "enabled" column. That way it would be possible to quickly view a torrent's contents and see which of the files are complete or nearly complete for example.

This is only a very minor issue as most torrents aren't that difficult to peer through, but shouldn't be an especially difficult one to implement, though it may depend on the OS or particular GUI system in use for each build.

Change History (20)

comment:1 Changed 12 years ago by haravikk

  • Type changed from Bug to Enhancement

comment:2 Changed 12 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

The files tab displays it in the order that it is stored in the torrent - this is desired because it lets you know what pieces might overlap. Sorting would as a result complicate this understanding.

comment:3 Changed 12 years ago by haravikk

  • Resolution wontfix deleted
  • Status changed from closed to reopened

That's not very useful information IMO, as I can't really think of any case when I'd want to know that, whereas being able to sort by % completed or by name is way more useful.

By all means keep the default behaviour, but allow users to click column-headings to choose a different sort-order. To allow users to go back to the default (torrent) order, then a new column can be added which simply shows what position the file is within the torrent.

The following options I think are the most useful:

Default (as it is now, though I personally never need it or see why I ever would) Name Size Progress Type (text, movie, music, unknown or whatever)

Some of these would either need to be implemented by adding some optional columns which can be enabled by right-clicking the column-header, or by using some kind of sort-menu attached to a widget perhaps.

In my own usage I'm especially interested in progress, as if I'm downloading a big torrent I usually like to find the most complete file, and have a look to see what kind of quality I can expect from the rest, or even find out the language. As there's nothing worse than downloading something you think is what you were looking for only to find out it's nothing like what you expected it to be because the language was listed in correctly, or whatever.

comment:4 Changed 12 years ago by livings124

  • Resolution set to invalid
  • Status changed from reopened to closed

I am not interested in implementing this, as discussed earlier. I'll consider if you submit a patch for it.

comment:5 Changed 12 years ago by haravikk

  • Resolution invalid deleted
  • Status changed from closed to reopened

What in the hell point is there in having a tracker if you're just going to close everything and tell me to do the work myself? If I had the time to set-up your project on my machine, and learn enough about a whole new code-base to implement this then maybe I would have done so already!

I submitted this issue with the lowest priority and a severity of trivial in the understanding that it's a pretty minor feature that someone already familiar with the code could probably implement fairly quickly, but is by no means an important problem.

It's not like I'm bloody well asking you to drop everything and implement this right away!

If you're not interested in implementing this yourself, then leave it open in case someone else feels inspired to do it. Closing it as invalid implies the idea makes no sense at all, unless you can clearly point out why it doesn't make sense to have the list sortable by other criteria if the user wishes, then it's NOT invalid, it's just not yet implemented.

comment:6 Changed 12 years ago by livings124

  • Resolution set to invalid
  • Status changed from reopened to closed

What's the point of me developing this program if people are going to force me to implement features I actively do not want. I have explained why I do not want this feature, and now you're hardening my stance on it. This will not be implemented.

comment:7 Changed 12 years ago by haravikk

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm not forcing you to do anything! I'm just trying to propose a small feature with obvious benefits, as a potential item for future inclusion in the program! It's a minor feature sure, but it's also a no-brainer when it comes down to it as there's a list in the program which could clearly benefit from being sortable, so why immediately dismiss it and take the stance of "Oh no it's sorted in a particularly useless way already so why give users the option of doing anything different"?

I don't care if you don't want to do it right now in order to focus on other, more important features, bugs or whatever, but there is no logical reason to just declare it as never going to be implemented!

I was under the impression that that's how open-source projects work within a tracker; people post enhancements or bugs, then developers pick up important ones or ones they feel they can commit to working on. Other issues just remain open until that happens, or budding enthusiasts are also free to pick up an issue and implement if they want, all in the spirit of co-operation etc.

But what you're doing is declaring a perfectly useful enhancement as invalid! It isn't an invalid suggestion! That you don't want to work on it yourself is irrelevant; I might take the time to do it if I can find any (unlikely as I only have time to argue this in the first place because I'm stuck on a shitty old computer until my main one is fixed), likewise someone else might leap in and work on it if they feel inspired to do-so. But they're not likely to do that if the issue is falsely marked "invalid" now are they?

comment:8 Changed 12 years ago by livings124

  • Resolution set to wontfix
  • Status changed from reopened to closed

You are mistaken - just because it is open source does not mean you can dictate what features we have to add (even if, as you say, we don't add it right away). This feature will not happen - I would prefer it did not, now more than ever because of this back on forth. You are suggestion that every enhancement HAS to be put in, or at least kept open until they are; that is not the case. As one of the main developers, we do get to dictate the direction the program takes. If we did not, then every patch that is submitted or feature that is suggested would make the app a bloated, ugly, confusing piece of garbage. You have to respect the developers' vision for the app, which explicitly excludes some design choices.

Your privileges will be removed if you reopen this again.

comment:9 Changed 12 years ago by haravikk

It's an extremely simple feature with blatantly obvious benefits, however minor compared to other more urgent features! At least it is to those with eyes and the capacity to reason. It seems that this project has a tracker purely so that you can traipse around it applying half-baked excuses, backwards reasoning, and downright idiocy in far greater than average quantities. I seriously hope that you are not currently, nor ever will be, employed by an actual company, as they will almost certainly be bankrupt by weeks end of adding you to their team, as you seem to miss the point of project management, collaboration, feedback, and open-source entirely.

To hell with it; open-source and closed-mindedness are not a winning combination, someone bring on a fanfare when livings124 is rightly removed from the picture, as Transmission will otherwise surely be run into the ground otherwise. There is no benefit to me posting /genuinely useful enhancements or bug-reports/ while livings124 is still around to instantly close them without ever supplying a valid reason.

comment:10 Changed 12 years ago by livings124

You're right, my involvement has ruined this project! Ruined! And I will call my employer to have myself removed from my post this instance!

(Oh, didn't notice you were the same person that opened such gems such as "allow encryption per-torrent" and "per-torrent Growl options". On second thought, please don't stop posting requests, yours are always quite entertaining.)

comment:11 Changed 12 years ago by haravikk

And yet you didn't come up with a single valid reason why any of them shouldn't be implemented, precisely as you have done with this. Your only tactic seems to be to re-iterate unreasoned points without ever actually arguing against the issue except on the basis of "I don't wanna, you can't make me", until eventually any potential for gain is eradicated by your tirade of inane drivel.

I posted each issue as a user of Transmission, thereby each issue has genuine use-cases from a genuine user, you know, the people that actually (used to) use the program; none of them may have been particularly urgent items, but that does not make any of them invalid, as details are just as important as the big issues.

A good open-source developer requires a degree of open-mindedness and good judgement that you do not posses, as open-source by definition does not have customers you are required to show a certain degree of interest in. Open-source is all about inclusion, and collaborative prioritisation, which I have enjoyed on other projects, but you seem to have replaced it here with power-play and ass-hattery; a prime example of a badly managed open-source project, and an utterly pointless installation of an issue-tracker, since it may as well not be here.

comment:12 Changed 12 years ago by livings124

And I am done here. You only hear what you want to hear, ignoring any point I make on your "requests"; we're not going to get anywhere.

comment:13 Changed 12 years ago by charles

I think this ticket has stopped being about any particular feature and is now about the two of you shouting each other down.

haravikk: Scanning over this ticket, and also some of your other tickets whose comments sections have similar downward spirals, I suspect your suggestions would get further if you handled your side of the discussion in a less confrontational way. Even though I'm sympathetic to this feature, I hate the idea of sticking up for it after you've been so hamfisted and excessively insulting.

On the other hand, you may have a great career ahead of you in AM talk radio.

comment:14 Changed 12 years ago by haravikk

I hear what I want? Livings124 please re-read all the issues, they follow a fairly similar pattern:

  • I post a perfectly reasonable request, minor perhaps but useful compared to the effort it would take for an existing developer to implement.
  • You swoop in and close the request either with a very poor reason against, or none at all until prompted.
  • I counter-argue why the reason against isn't a good one, and/or offer compromises or implementation details.
  • You re-iterate the same reason, apparently ignoring my response or declining to comment on it (i.e - no actual dialogue).
  • I attempt to re-word thinking maybe I just didn't communicate it properly the first time.
  • You ignore this attempt again.
  • Both of us get annoyed.

The lack of any real dialogue from you means nothing useful can come from any of the issues. I've seen it a number of times before, and I'm sure it'll continue to happen in projects around the world for years to come because people like you never realise this. I'm not without my own faults, but I know I'm stubborn, and become very snippy when annoyed, but if someone can actually give me valid counter-arguments I will back-down gracefully, but I've yet to receive any!

But you needn't worry, you can get your precious last word in as I've now said all I really can, as I should have realised sooner that arguing about a closed minded person's closed mindedness was an act of futility.

@Charles; I'll admit I've probably got annoyed sooner in this issue, but it's because of the same crap happening in the previous issues I've posted. I only get "excessively confrontational" if I'm given no clear reasoning against what I'm proposing, which you can clearly see happened in all cases, heated responses are the natural conclusion of this. How am I supposed to counter-argue a point if none was properly made?

But by this point I don't really care either way if it gets implemented.

comment:15 Changed 12 years ago by nthitz

I too would like to see this feature. It seems to be in most torrent clients and would be awfully helpful. Not having it is one of my biggest problems with Transmission.

However given what has occurred so far regarding this bug, I would be surprised if it happens. Here's hoping though!

comment:16 Changed 12 years ago by somethingstrange

I was unaware of this ticket, when I posted a duplicate (http://trac.transmissionbt.com/ticket/2817) that was summarily closed.

The status of this feature is unfortunate, because I believe being able to sort would be very useful. The argument that keeping the list ordered as it is in the torrent just so that you might know what pieces overlap is extremely weak. I can't imagine many users really caring about the pieces themselves. It's just summary information, that provides no solid value. You could probably remove all mention of "pieces", including the pieces summary on the Activity page, and you wouldn't lose much.

Every torrent client I've used in the past has had a sorting feature, and they usually also retained a way to sort in the original file order. From what I've been told, the GTK+ Transmission client already has some sorting capabilities.

Oh well. One can hope another developer will pick this up and submit a patch, and that the patch will actually be accepted and integrated.

comment:17 Changed 12 years ago by Form

Although I think this discussion has degenerated to a certain extent, I find that I completely agree with haravikk's feature idea and motivation.

Personally this is one feature I would use all the time (and I'm sure many others would) and one that I miss from other clients. It may not be useful for torrents with a handful of files (yet it may still be) but for torrents with a large amount of files it is an absolute necessity and there are a lot of those online.

My points in favor of this feature:

  • Finding a file by name in a very long list of files / folders (alphabetical sort).
  • Knowing which files are bound to finish downloading first (percentage sort).
  • Gathering the files selected for download at the top of the list (instead of scrolling the whole list looking for the sparse checked items) (download sort).

I almost posted a duplicate for this but then I read through this ticket and honestly I can't see (nor read) the reasoning behind the decision not to include the feature (or at least leave the ticket open), as haravikk has so vigorously defended.

@livings124 I don't mean to add fuel to the fire (or be disrespectful, I know you are a major contributor to the project, thanks for that) but all I've seen in your responses to haravikk's posts were your personal interest or rights in implementing the feature, and no actual reasoning on usability, the amount of work required to implement the feature or what would be best for the majority of Transmission users. I that not expected (however little) for an open-source project? I can understand haravikk's frustration. Wouldn't it be best to share the motivation behind not including this feature with the interested parties? I also don't think haravikk's other feature requests (however unenlightened they may be, no offense meant, haravikk) change the validity of this one at all.

I may be able to take the time to make a patch for this between my university courses but unfortunately from the looks of this thread it seems like it would be rejected instantly. Unless I know I won't work for nothing then I guess it won't get done by me.

Again, I don't mean to offend anybody at all, just my 2¢.

comment:18 Changed 12 years ago by Form

  • Cc fortinmike@… added

comment:19 Changed 12 years ago by charles

  • Component changed from Transmission to Mac Client
  • Keywords feature-disparity added; file tab sorting inspector removed

Recategorizing this ticket as "Mac" since the GTK+ client already does this.

comment:20 Changed 12 years ago by somethingstrange

Now you're just rubbing it in! ;)

Note: See TracTickets for help on using tickets.