Opened 11 years ago

Closed 10 years ago

#2646 closed Bug (duplicate)

Torrents merge/overwrite

Reported by: Deluxe Owned by: livings124
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.76
Severity: Normal Keywords: file overwrite merge same name
Cc:

Description

Have an issue with two different torrents that happen to have top directory and file(s) with same names.

When downloading on MacOSX 10.6 (each time in 'Downloads' directory), Transmission merged the two torrents, resulting in a mix of the two torrents files in the same directory, and seems to constantly overwrite file(s) with common name.

The bug is reproducible with: http://www.torrentz.com/61d683b12259c950dd4000e3e25051dc278a0c6e and http://www.torrentz.com/199ae60e2de11ac911847010d784d764e1713561

This bug quite like http://trac.transmissionbt.com/ticket/1258 but in this case, torrents are not the same (except for some names) and should not be merged/overwrited.

Change History (7)

comment:1 Changed 11 years ago by charles

I agree this isn't a literal duplicate of #1258 (thanks for searching trac before filing the ticket, btw :), but IMO the underlying cause is the same... Transmission intentionally doesn't worry about torrents overlapping each other.

IIRC the problem here was that the old behavior was for Transmission to refuse download two torrents whose root directory had the same name, and that bothered several people because some torrents are designed to nest in a hierarchy with other torrents.

The new behavior is for Transmission to not to any tests at all, thus allowing the previous paragraph's use case to work, but also letting files overwrite each other as described in this ticket.

Perhaps we can thread the needle here -- allow directory names to overlap, but don't allow the "leaf" files in the tree (the ones that actually have content) to overlap.

livings, do you have an opinion on this?

comment:2 Changed 11 years ago by livings124

I think no matter what we do this is a situation where we can't please everyone. I'm neutral on the solution to this.

comment:3 follow-up: Changed 11 years ago by charles

This is made more complicated with the complete/incomplete directory... what happens if it doesn't overlap when downloading, but becomes overlapping once it's complete?

comment:4 in reply to: ↑ 3 Changed 11 years ago by Rolcol

Replying to charles:

This is made more complicated with the complete/incomplete directory... what happens if it doesn't overlap when downloading, but becomes overlapping once it's complete?

What if Transmission tests before moving and if file names collide, puts it in a subfolder with the torrent's hash as the name inside of the parent folder that they both share? Or just rename the second file by appending a "2" or whichever number comes next before the extension of the item?

comment:5 Changed 11 years ago by livings124

  • Component changed from Mac Client to Transmission

comment:6 Changed 11 years ago by Deluxe

Since merging is a intended behavior, maybe a simple warn asking for confirmation about merge/overlap before the new torrent starts could be sufficient.

comment:7 Changed 10 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

Marking this as a duplicate of #3215

Note: See TracTickets for help on using tickets.