Opened 12 years ago

Closed 12 years ago

#2649 closed Bug (invalid)

crashes when adding a torrent or clicking on an already active torrent

Reported by: brot Owned by: charles
Priority: Normal Milestone: None Set
Component: Qt Client Version: 1.76
Severity: Normal Keywords: qt crash
Cc: brot@…

Description

Hello everyone :)

I discovered transmission and it would be the ideal torrent-client for me. However, the qt-gui keeps crashing here. To reproduce i have to:

  1. start qtr (with a new local session)
  2. add a torrent
  3. crash

or (used for the backtrace):

  1. start qtr (remote session running on another pc)
  2. click on an already added torrent
  3. crash

I am using gentoo, and transmission-1.76 with qt-4.6.

Thanks for the help!

brot

Attachments (2)

qtr_bt (8.4 KB) - added by brot 12 years ago.
backtrace of the crash
qtr180b1_bt (8.0 KB) - added by brot 12 years ago.
backtrace of the crash with 1.80b1

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by brot

backtrace of the crash

comment:1 Changed 12 years ago by charles

  • Summary changed from the transmission qt-client crashes when trying to add a torrent or clicking on an already active torrent to crashes when adding a torrent or clicking on an already active torrent

comment:2 Changed 12 years ago by charles

brot: could you please get a backtrace from 1.80 beta 1? thanks!

Changed 12 years ago by brot

backtrace of the crash with 1.80b1

comment:3 Changed 12 years ago by brot

  • Version changed from 1.76 to 1.76+

comment:4 Changed 12 years ago by charles

  • Status changed from new to assigned
  • Type changed from Defect to Bug
  • Version changed from 1.76+ to 1.76

brot: thanks for the update :)

looks like this is the same assertion / same crash, so the bug was present at least as of 1.76, so I'm rewinding the Version tag back to 1.76.

comment:5 Changed 12 years ago by charles

Confirmed to work in Qt 4.5. Looks like maybe this is something new in Qt 4.6.0? I'll try installing Qt 4.6 and see how that goes.

comment:6 Changed 12 years ago by charles

brot, sorry this ticket has been idle for so long, but I was wondering if this is still happening for you. I'm using a nightly build with Qt 4.6 and am not seeing this error.

comment:7 Changed 12 years ago by charles

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

comment:8 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from assigned to closed

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. Thanks again!

Note: See TracTickets for help on using tickets.