Opened 11 years ago

Closed 11 years ago

#2666 closed Bug (fixed)

Transmission connecting to seeds (peers with 100%) while seeding

Reported by: BigBossman Owned by: charles
Priority: Normal Milestone: 2.00
Component: libtransmission Version: 1.76
Severity: Minor Keywords: needinfo
Cc:

Description

Tested on private torrents (purely seeding), transmission connects and remains connected to peers with 100% completion.

1.76+ (9746)

Attachments (4)

Screen shot 2009-12-13 at 7.15.38 PM.png (76.3 KB) - added by BigBossman 11 years ago.
Screen shot 2009-12-16 at 4.08.36 PM.png (82.6 KB) - added by BigBossman 11 years ago.
seeding-in-r10126.jpg (98.8 KB) - added by charles 11 years ago.
seeding in r10126
Screen shot 2010-03-16 at 1.41.11 AM.jpg (244.5 KB) - added by BigBossman 11 years ago.

Download all attachments as: .zip

Change History (19)

Changed 11 years ago by BigBossman

comment:1 Changed 11 years ago by charles

  • Severity changed from Normal to Minor

Does this happen in 1.76 as well?

Changed 11 years ago by BigBossman

comment:2 Changed 11 years ago by BigBossman

Looks like it does. See attached screenshot

comment:3 Changed 11 years ago by charles

  • Version changed from 1.76+ to 1.76

comment:4 Changed 11 years ago by m1b

I saw similar behavior with current nightlies on a well-populated public torrent this past weekend.

In contrast to the original report, the seeding nightly only seemed to stay connected to 1.75 and 1.76 seeder peers, and looked to disconnect just fine from non-T seeders.

comment:5 Changed 11 years ago by charles

  • Keywords needinfo added

I can't reproduce this in r10126. See attached screenshot.

Please answer these questions:

  • Is this reproducible?
  • If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed 11 years ago by charles

seeding in r10126

comment:6 Changed 11 years ago by livings124

I do see a couple of seeders still hang on when a download completes and turns to seeding.

comment:7 Changed 11 years ago by charles

Ah, I didn't try that test case. I'll give it a try

comment:8 Changed 11 years ago by charles

followup to my previous comment -- I'm seeing Transmission hang on for a little while, but less than 10 seconds after becoming a seed, so that doesn't worry me.

BigBossman?: are there any other nuances to this that I need to test? For example was it a partial seed (ie you'd finished downloading all the files you wanted, but had unchecked some that you didn't) or some other kink?

comment:9 Changed 11 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

I'm going to close this ticket. I don't know what caused the behavior, but I'm not seeing it, nobody else is reporting it, and the people who did report it are AWOL.

If you're still experiencing this behavior, please answer the questions above and reopen this ticket. Thanks!

Changed 11 years ago by BigBossman

comment:10 Changed 11 years ago by BigBossman

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 1.76 to 1.92+

Logs from Feb 11 on IRC..... Feb 11 12:48:37 <BigBossman?> charles: regarding #2666, I just opened a torrent and i'm connected to about 58 seeders Feb 11 12:49:26 <BigBossman?> charles: the torrent does have some files unchecked Feb 11 12:52:44 <BigBossman?> charles: I'm actually seeing this on multiple torrents still, all have some files unchecked

anyways... heres a new screenshot, as you can see still happening on multiple torrents

comment:11 Changed 11 years ago by charles

  • Version changed from 1.92+ to 1.76

comment:12 Changed 11 years ago by charles

Does this happen on both private and public torrents?

comment:13 Changed 11 years ago by BigBossman

It seems to happen less on public torrents, but I do see it on both public and private torrents.

comment:14 Changed 11 years ago by charles

BigBossman?: I'm still not seeing this happen. You've dug into the code in the past IIRC... Could you add some logging messages into peer-mgr.c to see why it's not disconnecting those seeds for you?

Last edited 11 years ago by charles (previous) (diff)

comment:15 Changed 11 years ago by charles

  • Milestone changed from None Set to 2.00
  • Resolution set to fixed
  • Status changed from reopened to closed

As before I'm still not seeing this happen, but even so, I think this is fixed in r10506 as a side-effect of those changes made for #3159

Note: See TracTickets for help on using tickets.