Opened 14 years ago

Closed 14 years ago

#267 closed Bug (invalid)

cross-compiler awareness

Reported by: oleo Owned by: somebody
Priority: Normal Milestone: Sometime
Component: Transmission Version: 0.80
Severity: Minor Keywords: cross-compile
Cc:

Description

Transmission is also used in embeded world where cross-compiling is necessary. Attached patch for r2474 checks this case and skips tests that cannot be performed when configuring.

OOPS. I've just noticed that there is configure.ac

Attaching patch anyway.

Attachments (1)

configure.patch (850 bytes) - added by oleo 14 years ago.

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by oleo

comment:1 Changed 14 years ago by charles

I'm not sure it makes sense to patch the old build system.

Does using "autogen.sh; ./configure" in the top-level directory address this correctly? If not, could you attach a patch for configure.ac?

comment:2 Changed 14 years ago by charles

oleo: ping

comment:3 Changed 14 years ago by oleo

  • Resolution set to invalid
  • Status changed from new to closed

Using autoreconf, cross-compilation works as intended with glibc and uclibc library on broadcom, ixp4xx, and other embedded hardware platforms.

Note: See TracTickets for help on using tickets.