Opened 11 years ago

Closed 11 years ago

#2676 closed Bug (duplicate)

Transmission writes to non-existent drive in '/Volumes'

Reported by: Waldorf Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.80
Severity: Major Keywords:
Cc:

Description (last modified by Waldorf)

I forgot to turn on my drive containing the download (and incomplete) directories. Stupid, I know. But, strangely, Transmission didn't agree and started to download (and write) the data happily.

It created a directory, equal to the normal path, in the /Volumes directory on the mac.

A safeguard may be in order here?

Reopen Note

It happened again. Though this isn't something I like to test, let me know if you need me to.

Change History (7)

comment:1 Changed 11 years ago by Waldorf

  • Description modified (diff)
  • Summary changed from Transmission writes to non-existent drive to Transmission writes to non-existent drive in '/Volumes'

comment:2 Changed 11 years ago by charles

  • Component changed from Transmission to libtransmission
  • Owner set to charles
  • Severity changed from Critical to Normal
  • Status changed from new to assigned

Fixed in trunk for 1.80 by r9974.

comment:3 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 Changed 11 years ago by Waldorf

  • Description modified (diff)
  • Resolution fixed deleted
  • Severity changed from Normal to Major
  • Status changed from closed to reopened
  • Version changed from 1.76+ to 1.91

comment:5 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from reopened to closed

This ticket has been superceded by #1017

comment:6 Changed 11 years ago by Waldorf

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Sorry, this is not a duplicate of #1017. This is a separate issue. #1017 talks about rechecking and blanking out the resume cache when a drive is absent.

This ticket is about T not noticing that a drive is absent in the first place and just writing it to where the drive would be mounted. /Volumes/.... I think the nix variant is /dev/....

comment:7 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from reopened to closed
  • Version changed from 1.91 to 1.80

I forgot to turn on my drive containing the download (and incomplete) directories. Stupid, I know. But, strangely, Transmission didn't agree and started to download (and write) the data happily.

and

I have all torrents on USB disks, which I forgot to mount before transmission start. So transmission didn't find any local data and apparently reset the .resume files, so now I have to verify all torrents again.

are two parts of the same issue.

Note: See TracTickets for help on using tickets.