Opened 14 years ago

Closed 14 years ago

#269 closed Bug (invalid)

speed limit not working

Reported by: jah Owned by: livings124
Priority: High Milestone: Sometime
Component: Transmission Version: 0.82+
Severity: Normal Keywords:
Cc:

Description

in the current built if scheduling is enabled, when speed limit comes on, torrent speeds get throttled (as expected). However when it turns off (as scheduled) torrents do not get going at all. No peers are connected to, and the only solution is to pause/start the torrent.

Change History (6)

comment:1 Changed 14 years ago by charles

  • Component changed from Transmission to OS X Interface

not sure if this is a libT or OS X issue, so I'm passing this to BMW to try & reproduce.

comment:2 Changed 14 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Seems that when you throttle the connection you don't download/upload to a lot of peers so they disconnect from you, and when you unthrottle they're still disconnected. This isn't really an issue with speed limit, and in my testing it seems to work fine.

comment:3 Changed 14 years ago by charlieMonroe

  • Component changed from OS X Interface to Transmission
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 0.80 to 0.82+

It doesn't work again. In the current build (even though reported as fixed in 3134), it doesn't work for me (at least for upload). I have the upload speed set to 7KB/s and it goes over 11KB/s. However, it doesn't reach the max, so I guess this might be a KB vs. kB issue?

comment:4 Changed 14 years ago by livings124

It's been over 200 revisions. Is this still an issue?

comment:5 Changed 14 years ago by charlieMonroe

I'm sorry, but I can't test it as I have no Internet connection available until November.

comment:6 Changed 14 years ago by charles

  • Resolution set to invalid
  • Status changed from reopened to closed

Since there's nobody who's reporting this behavior anymore, and because it's not reproducible, I'm closing the ticket.

If anyone sees trouble with speed limits in November or any other time, feel free to open a new ticket.

Note: See TracTickets for help on using tickets.