Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2698 closed Bug (worksforme)

Transmission loses metadata of downloaded torrents, needs to re-check downloaded data

Reported by: aperiodic Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.76
Severity: Major Keywords: metadata data location forgets lost
Cc:

Description

The last two times I have started Transmission, it seems to have lost varying amounts of metadata regarding my torrents.

For some that I've moved, it has lost the location, and a window pops up informing me of this and asking me to pick a new one. For others, it has forgotten that it finished downloading the file, and they are all paused with the note "waiting to check existing data." For others still, it has lost track of how much it has uploaded, and resets the ratio back to zero.

This happened with about 20 torrents the first time, and about 60 torrents the second time. I cannot find anything (tracker, file type, location) that all these torrents have in common–it seems to be random.

Change History (6)

comment:1 in reply to: ↑ description Changed 12 years ago by aperiodic

Sorry, I forgot to add that I am using the 1.76 Mac GUI client, and running it on Mac OS X 10.6.2.

comment:2 follow-up: Changed 12 years ago by livings124

Did you move them by hand? Only moving by using File > Move Data File To… is supported.

comment:3 in reply to: ↑ 2 Changed 12 years ago by aperiodic

Replying to livings124:

Did you move them by hand? Only moving by using File > Move Data File To… is supported.

I moved them using File > Move Data File. I don't believe that's the cause of this issue, as some torrents that have not been moved are also losing metadata and need to be re-checked.

comment:4 Changed 12 years ago by livings124

Can you see if this persists in the 1.8 beta?

comment:5 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

I'm not completely sure what you mean when you refer to "metadata" in this context, but with the given info there's nothing I can do.

comment:6 Changed 12 years ago by aperiodic

What I mean by "metadata" is however Transmission keeps track of total amount downloaded and uploaded for a particular torrent. That is what is being lost, as many torrents that I know I've uploaded data on show a ration of 0.0, and some torrents which have been seeding for a while have to be re-checked.

I have not tried using the 1.80 beta, as it's not allowed on the trackers I use. Once it is, I'll see if this issue persists.

Note: See TracTickets for help on using tickets.