Opened 12 years ago

Closed 12 years ago

#2700 closed Bug (duplicate)

Flawed verification during downloading

Reported by: Tantali Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.76+
Severity: Normal Keywords:
Cc:

Description

When downloading a file, once it is finished, it is possible that the data isn't 100% verified even though it says so. Meaning that after you've downloaded a complete file, if you manually verify it again, it will notice that 1 segment isn't downloaded correctly. (and yes, the data itself was indeed flawed)

As far as I know, this is a relative new bug. I noticed it for the first time 2 weeks ago.

Change History (7)

comment:1 Changed 12 years ago by charles

Thank you for taking the time to report this bug and helping to make Transmission better. Please answer these questions:

  • Is this reproducible?
  • If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

comment:2 Changed 12 years ago by Tantali

It should be reproducible if you can find a torrent which is seeded by peers with faulty data.

e.g.: mp3's are often seeded with modified data (the seeder has adjusted the ID3-tags), resulting in faulty data at the downloaders end

In my case I got approx 10% failed download compared with the total download. And apparently some of these flawed packets make it through the verification during the downloading.

comment:3 Changed 12 years ago by charles

I haven't been able to trigger this bug.

Do you have a link to a .torrent I can use to test this?

comment:4 Changed 12 years ago by Tantali

No, not really.

But I'll be sure to keep the torrent the next time I encounter this.

comment:5 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.

comment:6 Changed 12 years ago by Tantali

  • Resolution invalid deleted
  • Status changed from closed to reopened

I've encountered yet another torrent with this behavior. However, it's from the private tracker WCD, I can only supply the torrent if you have an account there.

Note however that the occurrence of this bug strongly depends on the amount of flawed data you get from the swarm. There's no guarantee that the bug will manifest. In this case I had 1 flawed piece (128 KB) for a torrent of 90 MB with 5 MB of failed download.

comment:7 Changed 12 years ago by Tantali

  • Resolution set to duplicate
  • Status changed from reopened to closed

Just noticed that this is the same bug as #1242.

Note: See TracTickets for help on using tickets.