Opened 11 years ago

Closed 11 years ago

#2704 closed Bug (duplicate)

Pausing one torrent brings transfer rate to zero

Reported by: jrummer Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.76
Severity: Normal Keywords:
Cc: pcmaniac@…

Description

version 1.76 (9392) macbook, leopard 10.5.8

if i have multiple torrent running and i pause one, it stops/pauses all the torrents. i generally refresh all to get the going again. this happens consistently. i did a search in the forums and didn't find anything on it.

thanks.

Change History (17)

comment:1 Changed 11 years ago by livings124

Refresh all? How do you try to pause the torrent?

comment:2 Changed 11 years ago by jrummer

I pause an individual torrent from the active list that's downloading (not the pause button at the top, then all the torrents stop. So I restart all from the main refresh button at the top.

comment:3 Changed 11 years ago by charles

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

I can't reproduce this at all. Is it an issue with the mac client?

comment:4 Changed 11 years ago by livings124

I can't reproduce this as well. Is it consistent? Does it occur in the nightlies/beta? I'm suspecting you might inadvertently be hitting the pause all button/key combo, since no one else has reported this.

comment:5 Changed 11 years ago by KosjerD

It happens here as well on 1.76 with osx 10.5.8 on a powerbook unfrequently. best chances to reproduce are if two downloads are running and you hit the the individual pause button (the tiny round one) of one torrent in the download file list. the paused torrent stops but the other torrent instead of going on unbothered steps down to a transferrate of 0. announce and scrape of the torrent are still active and ok but down to a 0 downloadrate. after a while before a re announce and rescrape takes place the torrent restarts again.

comment:6 Changed 11 years ago by jrummer

Yes!!! That is exactly what happens for me. Perhaps a fix in the next update? Thanks.

comment:7 Changed 11 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles
  • Summary changed from Pausing one torrent stops all torrents to Pausing one torrent brings transfer rate to zero

Ok, that's a lot clearer. Can you both try the beta of 1.80 or a current nightly build and report back.

comment:8 Changed 11 years ago by jrummer

Downloaded the latest successful build and the issue still exists. I believe the build was 7 hours old. Thanks.

comment:9 Changed 11 years ago by jrummer

beta version seems to fix the issue. sorry about that...i had trouble finding the beta version.

comment:10 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

Glad to hear it :)

comment:11 Changed 11 years ago by jrummer

the beta version has closed on me each time i try to use it, after a few minutes of use. I'll just deal with the issue until the beta is deemed worthy of a standard release. thanks!!!

comment:12 Changed 11 years ago by livings124

If users don't report bugs until after release, then the release would have bugs... Please post the crash report.

comment:13 Changed 11 years ago by jrummer

  • Version changed from 1.76 to 1.76+

where are the error logs stored?

comment:14 Changed 11 years ago by pcmaniac

  • Cc pcmaniac@… added

i just had this bug appear in 1.91 (10268), osx 10.5.8

comment:15 follow-up: Changed 11 years ago by elias

  • Resolution fixed deleted
  • Status changed from closed to reopened

I am still experiencing this issue.

Transmission 1.92 (10363) Mac OS X 10.6.2 (Snow Leopard) MacBook? Pro C2D with 4GB of RAM

This only seems to happen when there are several active transfers. If it's just one or two transfers, this issue does not present itself. Transmission basically "freezes" the transfers for about a minute or two and then seems to pick-up where it left off (usually at nearly the same speed as before). It doesn't seem to "start over" (like a pause/resume). Thanks.

comment:16 Changed 11 years ago by charles

  • Version changed from 1.76+ to 1.76

comment:17 in reply to: ↑ 15 Changed 11 years ago by charles

  • Resolution set to duplicate
  • Status changed from reopened to closed

Replying to elias:

I am still experiencing this issue.

Transmission 1.92 (10363) Mac OS X 10.6.2 (Snow Leopard) MacBook? Pro C2D with 4GB of RAM

This only seems to happen when there are several active transfers. If it's just one or two transfers, this issue does not present itself. Transmission basically "freezes" the transfers for about a minute or two and then seems to pick-up where it left off (usually at nearly the same speed as before). It doesn't seem to "start over" (like a pause/resume). Thanks.

Aaaaaah

light bulb goes on

What's happening is Transmission is freezing while that torrent's files are being closed and flushed to disk. This pauses all of Transmission because the disk IO isn't done in a separate thread.

Marking this as a duplicate of #1753, which is a ticket to move disk IO to a separate thread.

Note: See TracTickets for help on using tickets.