Opened 12 years ago

Closed 12 years ago

#2711 closed Bug (fixed)

No metadata exchange when using magnet links and trackerless torrents

Reported by: koma Owned by: charles
Priority: Normal Milestone:
Component: libtransmission Version: 1.76+
Severity: Normal Keywords:
Cc: koma@…

Description

I'm running a up-to-date svn-build and I'm trying to start a trackerless torrent between just a couple of clients using a magnet link.

I can see that the clients connect to each other using the bootstrap server and DHT. But there is no exchange of metadata.

It seems like the msgs->torrent->infoDictLength is 0 in sendLtepHandshake() (peer-msgs.c). And because of that "metadata_size" won't be added to the handshake...

I don't know where to continue looking for this problem. With some guidance I guess I could dig a bit further in the sources.

Change History (3)

comment:1 Changed 12 years ago by koma

  • Cc koma@… added
  • Version changed from 1.76 to 1.76+

comment:2 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.80
  • Status changed from new to assigned

confirmed... thanks for the report

comment:3 Changed 12 years ago by charles

  • Milestone 1.80 deleted
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk for 1.80 by r9866

Note: See TracTickets for help on using tickets.