Opened 12 years ago

Closed 12 years ago

#2716 closed Enhancement (fixed)

Magnet Torrents not being saved after quit

Reported by: Waldorf Owned by: charles
Priority: Normal Milestone: 1.90
Component: libtransmission Version: 1.80
Severity: Normal Keywords:
Cc: ak@…

Description

If T hassen't received the metadata of a magnet torrent yet, it won't save the torrent after a quit.

Change History (9)

comment:1 Changed 12 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

comment:2 Changed 12 years ago by charles

  • Type changed from Bug to Enhancement

comment:3 Changed 12 years ago by monk

  • Cc ak@… added

comment:4 Changed 12 years ago by charles

  • Version changed from 1.76+ to 1.80

comment:5 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.90

comment:6 Changed 12 years ago by charles

  • Status changed from new to assigned

Implemented in trunk for 1.90 by r10084

comment:7 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:8 Changed 12 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopened due to regression reported by Rolcol:

Transmission doesn't keep track of the torrent files after the metadata has been grabbed from the peers since it names them after the temporary name of magnet links. Restarting the client is a bad fix.

comment:9 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

this regression is fixed now in trunk for 1.90 by r10109

Note: See TracTickets for help on using tickets.