Opened 12 years ago

Closed 12 years ago

#2727 closed Bug (fixed)

All my peers disappeared after upgrading from 1.80b3 to 1.80b4

Reported by: ascanio Owned by: livings124
Priority: Normal Milestone: None Set
Component: Transmission Version: Other
Severity: Normal Keywords: needinfo
Cc:

Description

I was downloading a file from 15 of 89 peers a minute before the upgrade, went to 0 of 0 straight after. I have restarted, closed Transmission a couple of times, without any result. It's been hours and nothing has changed...

The strange thing is that I can see Transmission contacting several peers through a network monitor, even if I pause all transfers!

What can I do?

Change History (13)

comment:1 Changed 12 years ago by ascanio

  • Keywords Mac version added

comment:2 Changed 12 years ago by charles

  • Keywords needinfo added; Mac version removed
  • Priority changed from Highest to Normal
  • Severity changed from Blocker to Normal
  • Summary changed from from 1.8b3 to 1.8b4 all peers disappeared! :( to All my peers disappeared after upgrading from 1.80b3 to 1.80b4

Thank you for taking the time to report this issue and helping to make Transmission better. However I'm not able to reproduce this behavior. Does it happen on all torrents, or just one? If you try a public torrent, such as a Linux iso or something from legaltorrents.com, do those downloads proceed correctly?

comment:3 Changed 12 years ago by ascanio

I've tried with many torrents... no way... they are all read (no sources). They are reported to be working and "healthy" (more than 500 sources on the tracker, none on my mac)

The rest of the network works fine, my Mac is well tuned.

Sorry for the wrong settings of the ticket and thanks for getting back to me so shortly!

comment:4 Changed 12 years ago by ascanio

Can I downgrade to 1.8b3 without losing data? If yes... where do I find the right build to download?

Cheers

comment:5 Changed 12 years ago by charles

I've tried with many torrents... no way... they are all read (no sources)

I don't know what this means, "they are all read (no sources)".

If you try to download, say, http://www.legaltorrents.com/torrents/821-six-desktop-wallpapers, does 1.80b4 connect to peers? does it start downloading?

comment:6 Changed 12 years ago by ascanio

Nothing, man... :(

It stalls at 0 peers... no network activity.

comment:7 Changed 12 years ago by ascanio

sorry it was:

"they are all RED (no sources)"

my mistake :)

comment:8 Changed 12 years ago by charles

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

I've just confirmed that the "six desktop wallpapers" torrent is working for me in 1.80b4 so I'm suspecting some sort of configuration error on your system rather than a Transmission bug...

Reassigning to "mac client" so that BMW can weigh in on this; I don't know where the "no sources" text comes from...

comment:9 Changed 12 years ago by ascanio

I can tell you that the app stalls (rainbow wheel) when it starts. (I can see the window, but I can't do anything for at least 3-4 mins) Then it just waits for sources... but I can tell you I can't see any network activity.

Any file I can delete (I need to keep the incomplete data downloaded so far!) or any way I can go back to 1.8b3? I know that if I go back to 1.73 I'll have all my data deleted (it happened me before... I believe it's because 1.8x supports a different file manager)

My router is well configured (my port appears OPEN in the preferences) and both my Mac and my ADSL connection are fine.

I hope we can solve it... :(

Thanks again

comment:10 Changed 12 years ago by livings124

  • Component changed from Mac Client to Transmission

This is working fine for me for b4 on Mac. Reassigning.

comment:11 Changed 12 years ago by charles

1.80 beta 3 can be found at http://download.m0k.org/transmission/files/Transmission-1.80b3.dmg ... as you suggested downgrading, could you reinstall beta 3 and see if it fixes things for you?

comment:12 Changed 12 years ago by ascanio

ok... I've been working on it and this is what I realized:

one incomplete torrent was keeping all the others in stall. As I deleted the torrent, moved the files to another folder and restarted the app, 1.8b4 was working fine.

The problem was that as soon as I was putting the (old) torrent back in, everything was going back to 0 sources. I tried even to verify the local data... but it appeared ok.

Therefore, I decided to go back to 1.76, carefully moving and setting the app so that it could read the partially downloaded files. I also deleted completely the content of ˜/Library/Application? Support/Transmission?

After having re-added the (old) torrent and placed the partial file in the appropriate folder, I verified once more the content of the local data first. Transmission 1.76 verified it and gave me 15 of the 19 gigs I was downloading as good data.

Hence, I believe the whole trouble started when 1.8b4 perhaps didn't verify the data correctly and kept Transmission to work.

Right now, it is downloading fine (old and new torrents). I think I will stick with 1.76 a bit... then upgrade the beta to test it as soon as I finish downloading this file :)

Thank you very much for your kindness. I hope my ticket at least gave you useful elements to work on.

All the best

comment:13 Changed 12 years ago by ascanio

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.