Opened 12 years ago

Closed 12 years ago

#2731 closed Bug (invalid)

Assertion failed: (winner >= 0) in fdlimit.c:539

Reported by: nijikon Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.76+
Severity: Normal Keywords:
Cc:

Description

transmission exited:

Assertion failed: (winner >= 0), function tr_fdFileCheckout, file fdlimit.c, line 539. Abort trap: 6 (core dumped)

OS: FreeBSD 6.2-RELEASE-p3 Transmission: trunk

Change History (6)

comment:1 Changed 12 years ago by charles

  • Component changed from Daemon to libtransmission
  • Owner set to charles
  • Summary changed from Abort trap: 6 (core dumped) to Assertion failed: (winner >= 0) in fdlimit.c:539

comment:2 Changed 12 years ago by charles

What is the value of `open-file-limit' in your daemon's settings.json file?

comment:3 Changed 12 years ago by nijikon

"open-file-limit": 32

comment:4 Changed 12 years ago by charles

I don't yet see in the code how this can happen. Is this crash reproducible?

comment:5 Changed 12 years ago by nijikon

i got this the first time, didn't get this earlier

how can i run transmission to catch this?

comment:6 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

After looking at your other ticket <http://trac.transmissionbt.com/ticket/2724#comment:13>, I very strongly suspect that the Transmission failures you're seeing are either due to a problem with how your local build was made, or with a configuration error in your system. If it's the former, you may be able to resolve it by using a prebuilt binary from FreeBSD. If it's the latter, you'll need to get technical support from the FreeBSD forums and FreeBSD volunteers. Unfortunately, I don't think this is a problem that can be resolved in Transmission's source code.

Note: See TracTickets for help on using tickets.