Opened 12 years ago

Closed 12 years ago

#2734 closed Bug (duplicate)

Transmission could lose all it's settings if "disk full" condition occurs.

Reported by: User294 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.76+
Severity: Major Keywords:
Cc:

Description

Transmission could lose it's settings if out of space condition occurs on volume where settings are stored. I'm using Transmission 1.76+ (9877) - GTK+ client

I got out of space condition on my system partition (Xorg server gone wild and flooded 200Gb into it's log file, completely wasting free space).
Upon reboot I found GTK+ Transmission client had lost all its settings (like speed limits, port to use, etc).

Idea is: Transmission could be more resilient to various disk issues. Write new settings to temp file first, and if this succeeds, remove old settings file and rename temp file to settings file. Else (if writing to temporary file fails), just keep original file and inform user that there was problem saving settings. At least this behaviour could prevent complete destruction of file with settings if write to file fails for some reason.

Change History (1)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for taking the time to report this bug and helping to make Transmission better. This particular bug has already been reported and is a duplicate of bug #2505, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Note: See TracTickets for help on using tickets.