Opened 12 years ago

Closed 12 years ago

#2736 closed Bug (invalid)

Web client still broken on WebKit browsers

Reported by: brentrockwood Owned by: kjg
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.76
Severity: Normal Keywords:
Cc: brent@…

Description

Despite ticket 1912 saying this is fixed, I am still seeing the same problem. No torrents show up in the client. Popup windows do not work. Same javascript error as in ticket 1912.

Result of expression 'stack[i].style' [undefined] is not an object. javascript/jquery/jquery.min.js:98

Fails in:

Chrome for Mac beta. Chrome for Mac dev build 4.0.288.1 All WebKit? nightlies I have tried. Safari 4.0.4 (6531.21.10)

My guess is that this is due to the WebKit? rendering engine itself as it is shared between Chrome and Safari/WebKit?, but the JavaScript? engines are not the same. Firefox3 works fine.

I have tried both the transmission binary from the Ubuntu 9.04 repository, as well as a built version from subversion (1.76). Same result.

Change History (2)

comment:1 Changed 12 years ago by kjg

Make sure you clear your caches, possibly you have an old js file lying around or something. I do all the dev for the web client on webkit browsers and it works for me.

It works just fine for me on Chrome 4.0.288.1 and later (currently running a snapshot of 4.0.292.0).

It also works for me on Safari 4.0.4 (6531.21.10)

I just installed the lately WebKit? nightly (r52951) and it seems to work there too.

I'll leave this open for now to give you a chance to gather more info, but this works for me so I'm stumped as to what you could be seeing.

comment:2 Changed 12 years ago by brentrockwood

  • Cc brent@… added
  • Resolution set to invalid
  • Status changed from new to closed

Problem was conflict between installed and built version of transmission. Works fine after uninstalling old version. Thanks!

Note: See TracTickets for help on using tickets.