Opened 11 years ago

Closed 11 years ago

#2750 closed Bug (fixed)

Crash on quit r9862 in TrCloseFile

Reported by: Waldorf Owned by: charles
Priority: Normal Milestone: 1.80
Component: libtransmission Version: 1.76
Severity: Normal Keywords:
Cc:

Description

I had a crash on quit, when updating to a newer nightly.

What I did: Start r9862 with all torrents paused. Added a new torrent to download. 50 torrents to start seeding. Quit (to update).

It took extraordinary long to quit, say 5 minutes.

Interesting bit

Thread 1 Crashed:
0   org.m0k.transmission          	0x0006b4e8 TrCloseFile + 112 (fdlimit.c:419)
1   org.m0k.transmission          	0x0006be04 tr_fdTorrentClose + 180 (fdlimit.c:617)
2   org.m0k.transmission          	0x00060264 stopTorrent + 124 (torrent.c:1461)
3   org.m0k.transmission          	0x00062abc closeTorrent + 184 (torrent.c:1496)
4   org.m0k.transmission          	0x00076414 tr_runInEventThread + 148 (trevent.c:292)
5   org.m0k.transmission          	0x00062264 tr_torrentFree + 104 (torrent.c:1518)
6   org.m0k.transmission          	0x0005cc74 sessionCloseImpl + 408 (session.c:1494)
7   org.m0k.transmission          	0x00076094 readFromPipe + 328 (trevent.c:178)
8   org.m0k.transmission          	0x000ac194 event_base_loop + 1236 (event.c:385)
9   org.m0k.transmission          	0x0007621c libeventThreadFunc + 160 (trevent.c:228)
10  libSystem.B.dylib             	0x92b2c0c4 _pthread_start + 316

Note

Look! Line numbers!

Attachments (1)

Transmission_2010-01-11-183432_G4.crash (27.9 KB) - added by Waldorf 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Waldorf

comment:1 Changed 11 years ago by charles

  • Milestone changed from None Set to 1.80
  • Status changed from new to assigned
  • Version changed from 1.76+ to 1.76

comment:2 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in trunk by r9915 for 1.80.

Looks like this was some kind of a race condition caused by Transmission taking so long to shut down. We can avoid this race by closing all the local files sooner when we begin the shutdown process.

Note: See TracTickets for help on using tickets.