Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2769 closed Bug (duplicate)

'Stop seeding:' changes

Reported by: Tantali Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.76+
Severity: Minor Keywords:
Cc:

Description

When downloading a few files of a torrent and thus completing the transfer, everything is normal. But if you then select a few extra files and resume the downloading, the 'Stop seeding:'-setting of the torrent switches to 'Seed forever'.

Change History (4)

comment:1 Changed 12 years ago by tiennou

See #460 if that ring a bell ;-). My point is that the behavior of Transmission is broken in this case : An application SHOULDN'T EVER change a user-specified setting, because it creates an inconsistency. But livings is right when he says that in this case a transfer that reached its ratio couldn't be restarted by the user resulting in unnecessary confusion for the user, so that explain the current behavior (since 0.6 blah). How I would fix that :

  • Stop T from tweaking the 'Stop Seeding' setting when the ratio completes, this fixes the inconsistency, and will (as a side-effect) make the Start All button only start transfers that haven't reached ratio.
  • When the user tries to start a transfer that has reached ration, display a warning window, which clearly states what is going on, with the following buttons : "OK" which will put back the transfer's 'Stop Seeding' setting to 'Seed Forever', and "Cancel", that does nothing.
  • Change the current "Start All (Forced)" toolbar button behavior so that Option-clicking it would force-start transfers.

comment:2 Changed 12 years ago by Tantali

rings a bell indeed :) Your solution seems like the better choice to me. In any case, the fact that it changes the settings right after the completion of the transfer instead of before a manual restart, seems totally unacceptable behavior to me...

comment:3 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #460 ;)

comment:4 Changed 12 years ago by Tantali

Well, it isn't completely a duplicate. #460 is about restarting of seeding, while this one is about resuming of downloading.

If you restart seeding, you could find it logical that that will work (and thus set it on 'seed forever'). But, if you download a few files of a torrent and a bit later you want to download some more of them (selecting the new files before you restart the transfer), you don't want your seeding-settings changed.

Note: See TracTickets for help on using tickets.