Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2770 closed Bug (worksforme)

torrent-set-location doesnt work if location contain white space

Reported by: mmaura Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.76
Severity: Normal Keywords: move torrent-set-location
Cc: bryce@…

Description

os: linux server: transmission-daemon

i use transmission-remote to move torrent location (contain white space).

transmission-remote 127.0.0.1 -t 2 --move '/home/xbmc/mediacenter/Serie TV/Suburban Shootout/' -n user:pass --debug

posting :

{"arguments":{"ids":2,"location":"\/home\/xbmc\/mediacenter\/Serie TV\/Suburban Shootout\/","move":true},"method":"torrent-set-location"}

response:

{"arguments":{},"result":"success"}

but nothing happen, no file moved i have tryed whithout white space, this work.

Change History (7)

comment:1 Changed 12 years ago by charles

I can't reproduce this problem.

[charles@sita daemon]$ ./transmission-remote -l | grep -i gnu
 152   100%     1.6 MB  Done         0.0     0.0   0.00  Idle         ipatrol - Gnu Privacy Guard 1_4_1
[charles@sita daemon]$ mkdir "/tmp/this path has spaces"
[charles@sita daemon]$ ./transmission-remote -t 152 --info | grep Location
  Location: /home/charles/Downloads
[charles@sita daemon]$ ./transmission-remote -t 152 --move "/tmp/this path has spaces" --debug
posting:
--------
{"arguments":{"ids":152,"location":"\/tmp\/this path has spaces","move":true},"method":"torrent-set-location"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc HTTP/1.1
User-Agent: transmission-remote/1.83+ (10124)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 111
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: emPSh6K80JB7bojtBjugfdRKSugo7U9yfMtgFnDHkWLVq9xi
< Date: Sun, 07 Feb 2010 02:35:47 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host localhost left intact
* Closing connection #0
posting:
--------
{"arguments":{"ids":152,"location":"\/tmp\/this path has spaces","move":true},"method":"torrent-set-location"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying ::1... * Connection refused
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc HTTP/1.1
User-Agent: transmission-remote/1.83+ (10124)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: emPSh6K80JB7bojtBjugfdRKSugo7U9yfMtgFnDHkWLVq9xi
Content-Length: 111
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Type: application/json; charset=UTF-8
< Date: Sun, 07 Feb 2010 02:35:47 GMT
< Content-Length: 36
< 
* Connection #0 to host localhost left intact
got response (len 36):
--------
{"arguments":{},"result":"success"}

--------
localhost:9091 responded: "success"
* Closing connection #0
[charles@sita daemon]$ ls /tmp/this\ path\ has\ spaces/
ipatrol - Gnu Privacy Guard 1_4_1
[charles@sita daemon]$ ./transmission-remote -t 152 --info | grep Location
  Location: /tmp/this path has spaces
[charles@sita daemon]$ 

comment:2 Changed 12 years ago by charles

Thank you for taking the time to report this bug and helping to make Transmission better. Please answer these questions:

  • Is this reproducible?
  • If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

comment:3 Changed 12 years ago by charles

  • Keywords needinfo added; torrent-set-location move removed

comment:4 Changed 12 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

I'm closing this bug report because it lacks the information needed to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. Thanks again!

comment:5 Changed 12 years ago by brycec

  • Cc bryce@… added
  • Keywords move torrent-set-location added; needinfo removed
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 1.76 to 1.91

I can reliably reproduce this (it's quite frustrating in fact). System is running a recent FreeNAS nightly, Transmission 1.91. Filesystem is mounted as "(ufs, local, soft-updates, acls)". When moving data, not only does the file not get moved, but it's also paused. Perhaps as a pause-move-unpause process that failed mid-execution? If I move to a directory without any spaces (in this instance, the parent), the move works fine and the torrent resumes seeding. I don't know what to tell you, it fails 100% reliably for me. What can I test? (Bear in mind this is a FreeNAS box, and I don't have the ability to simply compile from source. At least, I don't know how to.)

Failed

mammoth:~# transmission-remote --debug -t 24 --move /mnt/data/untitled\ folder\ 2/
posting:
--------
{"arguments":{"ids":24,"location":"\/mnt\/data\/untitled folder 2\/","move":true},"method":"torrent-set-location"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc HTTP/1.1
User-Agent: transmission-remote/1.91 (10268)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 115
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: A3KxiReqWTueEzLbOoWwHRmPSchuRtzwDdAlOP4nApHHoa1C
< Date: Tue, 06 Apr 2010 18:56:39 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host localhost left intact
* Closing connection #0
posting:
--------
{"arguments":{"ids":24,"location":"\/mnt\/data\/untitled folder 2\/","move":true},"method":"torrent-set-location"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc HTTP/1.1
User-Agent: transmission-remote/1.91 (10268)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: A3KxiReqWTueEzLbOoWwHRmPSchuRtzwDdAlOP4nApHHoa1C
Content-Length: 115
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Type: application/json; charset=UTF-8
< Date: Tue, 06 Apr 2010 18:56:39 GMT
< Content-Length: 36
< 
* Connection #0 to host localhost left intact
got response (len 36):
--------
{"arguments":{},"result":"success"}

--------
localhost:9091 responded: "success"
* Closing connection #0
mammoth:~# transmission-remote -t 24 -i | grep Location
  Location: /mnt/data/Downloads/

Success

mammoth:~# transmission-remote --debug -t 24 --move /mnt/data/
posting:
--------
{"arguments":{"ids":24,"location":"\/mnt\/data\/","move":true},"method":"torrent-set-location"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc HTTP/1.1
User-Agent: transmission-remote/1.91 (10268)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 96
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 409 Conflict
< Server: Transmission
< X-Transmission-Session-Id: 7CbIquAAaXFQTvb8siddwqobkP9Sox3uBUfx726QFELQV45H
< Date: Tue, 06 Apr 2010 19:06:25 GMT
< Content-Length: 580
< Content-Type: text/html; charset=ISO-8859-1
< 
* Connection #0 to host localhost left intact
* Closing connection #0
posting:
--------
{"arguments":{"ids":24,"location":"\/mnt\/data\/","move":true},"method":"torrent-set-location"}

--------
* Couldn't find host localhost in the .netrc file; using defaults
* About to connect() to localhost port 9091 (#0)
*   Trying 127.0.0.1... * connected
* Connected to localhost (127.0.0.1) port 9091 (#0)
> POST /transmission/rpc HTTP/1.1
User-Agent: transmission-remote/1.91 (10268)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
X-Transmission-Session-Id: 7CbIquAAaXFQTvb8siddwqobkP9Sox3uBUfx726QFELQV45H
Content-Length: 96
Content-Type: application/x-www-form-urlencoded

< HTTP/1.1 200 OK
< Server: Transmission
< Content-Type: application/json; charset=UTF-8
< Date: Tue, 06 Apr 2010 19:06:25 GMT
< Content-Length: 36
< 
* Connection #0 to host localhost left intact
got response (len 36):
--------
{"arguments":{},"result":"success"}

--------
localhost:9091 responded: "success"
* Closing connection #0
mammoth:~# transmission-remote -t 24 -i | grep Location
  Location: /mnt/data/

comment:6 Changed 12 years ago by brycec

  • Resolution set to worksforme
  • Status changed from reopened to closed

Update:
Re-examined my directory permissions... seems they were the issue. Directory was 755 root/wheel, changing to 777 or transmission's user resolved my issue.

There still remains the ancillary issue - Response is "success" when it clearly was not successful.

I am reverting this back to "closed"

comment:7 Changed 12 years ago by livings124

  • Version changed from 1.91 to 1.76
Note: See TracTickets for help on using tickets.