Opened 12 years ago

Closed 12 years ago

#2772 closed Bug (fixed)

Even after a magnet link gets metainfo, the Web GUI doesn't use that metainfo

Reported by: User294 Owned by: charles
Priority: Normal Milestone: 1.90
Component: Web Client Version: 1.80
Severity: Minor Keywords: backport-1.8x
Cc:

Description

Transmission 1.80 beta 5, daemon + web-interface used.

I did the following:

  1. Added some torrents as magnet links
  2. Waited until transfer completed.
  3. Taken a look on downloads info when they're completed. I did not closed browser tab while download is in progress.


Result:
Download displays something like this:
0 MB, uploaded NNN.N MB (Ratio M.M)

Expected:
Proper size of download should be displayed. Correct sizes will appear instead of 0 only when web interface completely closed and reopened again.

Change History (7)

comment:1 Changed 12 years ago by charles

  • Component changed from Transmission to Web Client
  • Owner set to kjg

comment:2 Changed 12 years ago by charles

  • Version changed from 1.76+ to 1.80

comment:3 Changed 12 years ago by charles

  • Summary changed from Web interface: files sizes listed as 0 for recently added transfers in web interface until you fully reload web interface manually. to files sizes listed as 0 for recently added transfers until you fully reload web interface manually.

comment:4 Changed 12 years ago by kjg

Is this still a problem? I'm unable to reproduce it.

comment:5 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.90
  • Owner changed from kjg to charles
  • Status changed from new to assigned

I see it... I think I can fix it.

comment:6 Changed 12 years ago by charles

  • Summary changed from files sizes listed as 0 for recently added transfers until you fully reload web interface manually. to Even after a magnet link gets metainfo, the Web GUI doesn't use that metainfo

comment:7 Changed 12 years ago by charles

  • Keywords backport-1.8x added
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk for 1.90 by r10114.

Added backport-1.8x for possible inclusion if/when we do another 1.8x release

Note: See TracTickets for help on using tickets.