Opened 12 years ago

Closed 12 years ago

#2785 closed Bug (fixed)

Groups functionality for file names doesn't work

Reported by: wtlau Owned by: livings124
Priority: Normal Milestone: 1.81
Component: Mac Client Version: 1.80
Severity: Normal Keywords: Groups
Cc:

Description

I have a group set up in transmission to move video files to my movie folder. The criteria I have set up was if any file name ended with a suffix that designated video (e.g. .avi, .mkv) it would be moved.

As of version 1.80, groups has not worked for me. Files have not been identified or moved. I have even tried changing it so that the criteria looks for file names that contain movie formats to no avail.

I don't think I'm using the function incorrectly, is this a bug?

Thank you.

Change History (11)

comment:1 Changed 12 years ago by livings124

I'm not having any trouble with this. I specify a "file ends in: .mpeg" to auto-assign to red, and adding a new transfer with that file extension sure enough adds it to red.

comment:2 Changed 12 years ago by wtlau

  • Resolution set to invalid
  • Status changed from new to closed

I tested it again and it seems to work now. Thanks.

comment:3 Changed 12 years ago by Waldorf

  • Resolution invalid deleted
  • Status changed from closed to reopened

Could it be that, for single file, but folder enclosed, files to go weird? Because, I'm randomly seeing this too. Also, as of 1.8 (maybe, maybe, I've noticed this in 1.7x too, but I'm on nightlies for too long to remember).

http://img.skitch.com/20100122-qtgeheq3k19jskwjqswd8ax2by.jpg

comment:4 Changed 12 years ago by Waldorf

Scrap that. I've tested on a single file, no folder, torrent and a folder containing movies. Same result.

Changing them to "contains" is the same.

Unless you can find an issue with my rules?

comment:5 Changed 12 years ago by Waldorf

Hmm. by Name works fine. So, just by Any File?

comment:6 Changed 12 years ago by charles

  • Component changed from Transmission to Mac Client

comment:7 Changed 12 years ago by livings124

  • Milestone changed from None Set to 1.81
  • Summary changed from Groups functionality doesn't work to Groups functionality for file names doesn't work

This should be fixed in r9997

comment:8 Changed 12 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:9 Changed 12 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed 12 years ago by charles

  • Owner set to livings124
  • Status changed from reopened to new

reopened to give proper attribution to livings

comment:11 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.