Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2801 closed Bug (duplicate)

Scheduler / Speed limit does not work fully - 0kB down is constrained to 16kB

Reported by: paxomega Owned by: livings124
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.82
Severity: Normal Keywords: Scheduler speedlimit
Cc:

Description

The scheduler / speed limit is not being fully applied on the Mac Client.

I have set a schedule to download only between 4AM-9AM (unlimited) and all other times download =0kB/s and unlimited upstream.

I upgraded from 1.77 due to stalled torrents never starting / completing (ie the time based constraints worked correctly).

Since upgrading all my constrained downloads are downloading at about 16kB/s when in constrained time. The downloads average at about 16kB (that's what is displayed) but there is a momentary increase to higher rates and then fall back to the 16kB average.

I have tried this on the official 1.8.2 client as well as the latest build 10008 http://build.transmissionbt.com/job/trunk-mac/lastSuccessfulBuild/artifact/trunk/release/Transmission-10008.dmg

I have tried pausing and unpausing the download - the 16kB/s remains. I have tried restarting the client and the entire machine (still 16kB/s) I have tried disabling the individual torrent "stay within global bandwidth limits" and then reenabling shortly after - the 16kB/s remains.

Change History (2)

comment:1 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 1.82+ to 1.82

Thank you for taking the time to report this bug and helping to make Transmission better. This particular bug has already been reported and is a duplicate of bug #2656, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

comment:2 Changed 12 years ago by livings124

  • Component changed from Mac Client to libtransmission
Note: See TracTickets for help on using tickets.