Opened 12 years ago

Closed 12 years ago

#2819 closed Bug (fixed)

announce URLs containing raw IP addresses don't work in 1.82

Reported by: scontin Owned by: charles
Priority: High Milestone: 1.83
Component: libtransmission Version: 1.82
Severity: Critical Keywords:
Cc:

Description

40 Ubuntu Intrepid Kernel 2.6.27-7-generic i386 clients on a OpenVPN VPN, with 2 Opentracker active on 2 servers in balancing mode. No problem at all with ping, every machine can view each other and the 2 trackers. All torrents ara shown correctly in trackers. No firewall inside VPN. No blacklists.

With transmission 1.76, 1.80 and 1.81 all works flawly, same setting.json. With Transmission 1.82 till 1.82+ r10028, torrents are stopped, download and upload. They won't never start.

Change History (13)

comment:1 Changed 12 years ago by charles

scontin: please reread http://trac.transmissionbt.com/ticket/2792#comment:21 and provide the information I requested there.

comment:2 Changed 12 years ago by scontin

I think i provided info to you :-)

"brad0 and scontin, please check to make sure your tracker(s) have whitelisted the version of Transmission that you're trying to use" No blacklist or whitelist of transmission versions

"Also please refer to http://trac.transmissionbt.com/wiki/SlowSpeeds"

  1. Is it your network? No
  2. Is your tracker responding? Yes
  3. Are there too many (or not enough) seeders? 40
  4. Is it your speed limits? No
  5. Is it a small swarm? No
  6. Are you uploading too fast? No
  7. Is it your ISP? No, different ISP
  8. Is it an old version of Transmission? 1.76 on 36 and 1.82+ on 4
  9. Is it your router or firewall making your "port closed"? No
  10. Is it a Transmission Bug? I think :-)

"and, if you don't find the issue, please report the details requested in that wiki page either via irc or in a new, separate trac ticket. Thank you!" Done :-P

comment:3 follow-up: Changed 12 years ago by scontin

Update: I tried also version svn 10031. Downloading of torrents won't start. As soon as I stop Transmission, downgrade to version 1.80, and start Transmission, torrents start immediately as usual :-)

comment:4 in reply to: ↑ 3 Changed 12 years ago by scontin

Replying to scontin:

Update: I tried also version svn 10031. Downloading of torrents won't start. As soon as I stop Transmission, downgrade to version 1.80, and start Transmission, torrents download start immediately as usual :-)

comment:5 Changed 12 years ago by charles

Thanks for the fast reply. This is an Ubuntu iso you're downloading? Could you attach the URL so that I can give it a try?

comment:6 Changed 12 years ago by scontin

http://releases.ubuntu.com/8.10/ubuntu-8.10-alternate-i386.iso

It's an ubuntu alternate, no gui, with this packages: openssh-server xserver-xorg mplayer openvpn xinit htop xfonts-base xfonts-scalable dialog xauth xterm xutils libdirectfb-extra ntp alsa-utils nagios-nrpe-server nagios-plugins nagios-plugins-basic python-bittorrent python-mpd mpd python-iplib pulseaudio python-simplejson python-twisted-web python-cjson libcurl3 libaosd2 libaosd-text2 uml-utilities icewm-lite hddtemp linux-headers-2.6.27-7-generic build-essential dkms libqtgui4 hwinfo curl

No dist-upgrades after install (we made unattended install)

We use web-interface to see torrents downloading

comment:7 Changed 12 years ago by scontin

Maybe I misunderstood. torrents downloading are all internal to our vpn :-)

comment:8 Changed 12 years ago by charles

scontin: the reason I asked was so that I could try jumping into the swarm to test. With that in mind, do you see the same downloading problems on publically available torrents, such as the ubuntu-8.10-alternate-i386.iso torrent available at http://torrent.ubuntu.com:6969/ ?

As a separate question: is it possible for you to run either transmission-remote or the GTK+ client for both versions 1.80 and 1.82 for testing?

comment:9 Changed 12 years ago by charles

scontin: actually if you're available for fast back-and-forth like this, maybe it would be even faster to come into #transmission on freenode.. :)

comment:10 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 1.83
  • Owner set to charles
  • Summary changed from torrents won't start in transmission 1.82 to announce URLs containing raw IP addresses won't announce/scrape in 1.82

comment:11 Changed 12 years ago by charles

  • Status changed from new to assigned
  • Summary changed from announce URLs containing raw IP addresses won't announce/scrape in 1.82 to announce URLs containing raw IP addresses don't work in 1.82

possible fix added to trunk in r10032

comment:12 Changed 12 years ago by charles

The issue of announcing to IP address URLs is confirmed fixed in r10032

comment:13 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.