Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2825 closed Bug (duplicate)

Changing port does not update uPnP mapping.

Reported by: alanfleming Owned by: livings124
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.82
Severity: Normal Keywords:
Cc:

Description

If you press "Randomize Port" in Preferences - Network, the UPnP mapping set by Transmission is not updated to the newly chosen port.

It should be automatically updated to match the newly chosen port.

Attachments (4)

openports-after.tiff (59.0 KB) - added by alanfleming 13 years ago.
Showing ports open after randomize
transmissionprefs-after.tiff (92.7 KB) - added by alanfleming 13 years ago.
Transmission prefs after randomize
openports-before.tiff (59.0 KB) - added by alanfleming 13 years ago.
UPnP mappings before randomize
transmissionprefs-before.tiff (92.3 KB) - added by alanfleming 13 years ago.
Transmission prefs before randomize

Download all attachments as: .zip

Change History (22)

comment:1 Changed 13 years ago by charles

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

I don't understand what you mean. Transmission lets you check to randomize on startup, not to randomize the existing session's port.

comment:2 Changed 13 years ago by livings124

I do not follow either. Clicking on the random port button sets a new port, just as if you typed it in manually.

comment:3 Changed 13 years ago by alanfleming

Assuming you have "Randomize port on launch" and "Automatically map port" ticked,

  1. at launch, Transmission chooses an random port and maps it open using UPnP.
  2. on pressing the "Random port" button, a new, different random port is set. But the UPnP mapping, set at stage 1, is not updated to reflect that Transmission is using this new port, rather than the one set at 1. above.

Verified by using Port Map to query my router to check the UPnP bindings.

comment:4 Changed 13 years ago by livings124

Is the behavior different when you see a new port manually? (make sure you're using 1.83)

comment:5 Changed 13 years ago by livings124

*set a new port manually

comment:6 Changed 13 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

The code is the same as manually entering in a new port. Please reopen with the requested info.

comment:7 Changed 13 years ago by alanfleming

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The *code* being the same is not a reason to close a ticket. The code being the same does not eliminate the possibility of a bug.

*Testing* is the reason to close a ticket with 'works for me'. I'll do the test you asked in the next couple of days.

comment:8 Changed 13 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Summary changed from Randomize port does not update uPnP mapping. to Changing port does not update uPnP mapping.

Ignoring my question until I close, and then complaining is not the way to get things done.

comment:9 Changed 13 years ago by livings124

And I did test, it does work for me. ;)

comment:10 Changed 13 years ago by alanfleming

Document what you did properly then :) That's what you asked me to do earlier! Documentation is the key to good testing :)

Also, your test doesn't necessarily answer what I think is the bug. If you changed the port manually and again by pressing the randomize button and the uPnP mapping did not update *either* time, then I think that is a bug. If it updates for manual, and not the button, that is a different bug.

No bug would be where the uPnP mapping updated on each change, whether that change was by pressing the randomize button or typing in a new port manually.

I've ripped my network here apart this weekend. I will answer the question you asked tomorrow.

comment:11 Changed 13 years ago by charles

alanfleming: any news on this?

comment:12 Changed 13 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

For all the reprimanding we've gotten in this ticket, it is far past the date where we were told we would get more information. I still cannot replicate this.

comment:13 Changed 13 years ago by alanfleming

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Absolutely confirmed here.

I've attached 4 files. Transmissionprefs-before shows it using a particular port. Openports-before shows that port mapped through via UPnP. You can see that it's open on the Transmission prefs.

Transmissionprefs-after is taken after I press "Randomize". You can see it's using a new port. You can see that port is closed. And you can see from Openports-after that it is *not* mapped via UPnP.

Therefore, as I said at the start, Transmission is *not* updating its UPnP mapping correctly when "Randomize" is pressed.

Changed 13 years ago by alanfleming

Showing ports open after randomize

Changed 13 years ago by alanfleming

Transmission prefs after randomize

Changed 13 years ago by alanfleming

UPnP mappings before randomize

Changed 13 years ago by alanfleming

Transmission prefs before randomize

comment:14 Changed 13 years ago by charles

(why on earth did you use an image format that web browsers don't understand... ;)

comment:15 Changed 13 years ago by alanfleming

I use a Mac. Transmission runs on a Mac. Safari on Macs understands tiffs. Grab, Macs' inbuilt screen capture program, spits out tiffs.

Why do you use a computer or operating system that doesn't just work? :)

comment:16 Changed 13 years ago by charles

Why do you assume the entire world revolves around you and behaves the same as you?

I would think that Mac users would well understand, from watching Windows users, the pitfalls of monoculture thinking.

comment:17 Changed 13 years ago by charles

  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing this ticket as a duplicate of #2892

comment:18 Changed 13 years ago by livings124

FYI, Mac OS generates PNGs when using the OS's picture taking functionality (no apps involved).

Note: See TracTickets for help on using tickets.