Opened 15 years ago

Closed 14 years ago

#283 closed Bug (worksforme)

daemon doesn't return status for certain operations; client times out instead

Reported by: tomster Owned by: swe
Priority: Normal Milestone: Sometime
Component: Daemon Version: 0.80
Severity: Normal Keywords:
Cc:

Description

Symptom

When adding a torrent to transmission-daemon via RPC, removing it again and then trying to re-add it, transmission-daemon doesn't send back an error message but simply prints a debug message transmission-daemon: XXX loaded duplicate torrent. The client, waiting for an answer (either the numerical id of the newly added torrent or a error message as per spec) eventually times out. After restarting the daemon, the torrent can be re-added again (but only once).

Expected behaviour

First of all, re-adding a removed torrent should be possible, however that seems to be covered in #278... This ticket is about not receiving an error message. What I expect is to receive a status message such as "succeeded", "failed", "not-supported", "bad-format", "info" as per the specification

Note: this symptom occurs also for other set operations such as downlimit, uplimit etc. The client doesn't receive an answer and must manuall verify success by explicitly calling get-downlimit etc.

Steps to reproduce

  1. start transmission-daemon
  2. add a torrent to transmission-daemon via RPC (the daemon returns the numerical id 1 as per specification.)
  3. remove the torrent via RPC
  4. repeat step 2 without restarting the daemon first.

Change History (5)

comment:1 Changed 15 years ago by charles

  • Component changed from Transmission to Daemon
  • Owner changed from somebody to charles

comment:2 Changed 14 years ago by charles

  • Owner changed from charles to SoftwareElves

comment:3 Changed 14 years ago by charles

  • Summary changed from transmission-daemon doesn't return status messages for certain operations - client times out instead to daemon doesn't return status for certain operations; client times out instead

comment:4 Changed 14 years ago by swe

  • Owner changed from SoftwareElves to swe

comment:5 Changed 14 years ago by swe

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.