Opened 12 years ago

Closed 12 years ago

#2830 closed Enhancement (invalid)

progress bar is solid green when seeding even if only part of torrent was downloaded

Reported by: kim Owned by: kjg
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.83
Severity: Normal Keywords: patch-needed
Cc:

Description

can't recall if this is a problem in native clients too.

When seeding a partially downloaded torrent (eg a few files out of a set) the progress bar shows 100% green. I'm deeming this a defect since it is misleading and has tripped me up twice now. Instead I believe it should show only x% green where x% is the amount downlaoded. Rest should be grey.

Optional later feature, map the pieces downloaded onto this bar so in this case it only shows green along the bar where the actual pieces are (resolution probably only 100-200 bins, less or none in compact mode)

Change History (6)

comment:1 Changed 12 years ago by charles

  • Milestone 1.90 deleted
  • Type changed from Defect to Bug

Please don't set milestones unless you've already talked it over with me or livings or kjg. Trac is mostly to blame for this; it doesn't seem to offer fine-grained control over who can set what ticket attributes. Still, I'm sure you can see that setting the developers' deadlines for them is not how things should be done. ;)

comment:2 Changed 12 years ago by kim

I'm a developer too...I was offering to fix it for 1.90. If you don't consider the rest of us who contribute code to be developers then mark T as a closed project and be clear about this on the wiki - you know - where it says "developers welcome...".

comment:3 Changed 12 years ago by David Munch

Developing code and managing the project is not really the same thing.. :)

Anyway, I wonder if this is related to sometimes downloading partial files from a torrent, where Transmission displays that it is downloading the entire torrent and not just a part of it? I've seen it one time.

comment:4 Changed 12 years ago by kjg

  • Keywords patch-needed added
  • Type changed from Bug to Enhancement

This is somewhat by design. I wanted to stick with only two divs for the progress bar. In the case of uploading, the darker green progresses along the lighter green signifies progress to the upload ratio, so that takes up both divs. Adding this would require a third div then for the blank space.

I wont be adding this, but I would happily accept a patch if someone else would like to have a go.

comment:5 Changed 12 years ago by charles

  • Milestone set to None Set

comment:6 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Reading through the original issue reported, this is by design, at least in the GTK+ and Web UI. The progressbar intentionally measures the progress of the files that you want, and ignores the files that you don't want.

Note: See TracTickets for help on using tickets.