Opened 12 years ago

Closed 11 years ago

#2834 closed Enhancement (duplicate)

Transmission-daemon use external configuration files specified on startup

Reported by: locke105 Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.83
Severity: Normal Keywords:
Cc: locke105

Description

As of now, transmission-daemon being able to reload its config file while running (SIGHUP) and being able to set the config directoy is a nice feature. However, on Gentoo (and i'm sure many other *nix distros) the norm for config files is to have a /etc/ config file that would be re-read on SIGHUP and startup. With transmission, although you can specify the config directory, having the daemon drop its blockfiles, downloads and stats.json in the same directory is not ideal.

It would be nice to be able to specify an external settings.json on startup that could be re-read with SIGHUP. Even better, maybe make each of the settings files/directories specifiable on startup.

Change History (2)

comment:1 Changed 12 years ago by locke105

  • Cc locke105 added

comment:2 Changed 11 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

closing this ticket as a duplicate of #2119

Note: See TracTickets for help on using tickets.