Opened 12 years ago

Closed 12 years ago

#2845 closed Bug (fixed)

value "-2147483648" of type `gint' is invalid or out of range

Reported by: charles Owned by: charles
Priority: Normal Milestone: 1.90
Component: GTK+ Client Version: 1.83
Severity: Normal Keywords:
Cc:

Description

This error message appears when opening the file list on a torrent which contains files whose size in the metainfo is 0 bytes. It's caused by a divide-by-zero when calculating the percentage done of that file.

Change History (2)

comment:1 Changed 12 years ago by charles

  • Owner changed from backport-1.8x to charles
  • Status changed from new to assigned

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk for 1.90 by r10052.

Added backport-1.8x tag. This is a small, safe bugfix that definitely should be considered if/when there is another 1.8x release.

Note: See TracTickets for help on using tickets.