Opened 14 years ago

Closed 14 years ago

#285 closed Bug (fixed)

Beachball when downloading to Samba Share

Reported by: mloiterman Owned by: somebody
Priority: Normal Milestone: None Set
Component: Transmission Version: 0.82+
Severity: Major Keywords: samba beachball
Cc:

Description

I have my download folder set to a network samba share.

Shortly after starting a download, Transmission starts showing a beach ball and completely locks up. It never recovers. The app must be force quit, which takes a good five or so minutes.

This occurs on many different torrents. I have tried reinstalling the app, deleting all prefs and app support folder and stopping and then adding back in all torrents. Nothing helps.

Change History (15)

comment:1 Changed 14 years ago by mloiterman

I should note, everything works fine if I set the download folder to a local folder.

comment:2 Changed 14 years ago by mloiterman

Upon further investigation, it appears that it does not completely lock up. It stalls while trying to write the files. This is odd, since .72 did not show any of these problems.

comment:3 Changed 14 years ago by tiennou

  • Milestone changed from Sometime to 0.90
  • Version changed from 0.80 to 0.82+

Update on this one : Workaround : I'm connecting to smb://localhost, and set my download folder to the mounted samba share. I see no beach-ball appearing, if someone can double-check this, then it can be closed

comment:4 Changed 14 years ago by livings124

  • Milestone changed from 0.90 to None Set

comment:5 Changed 14 years ago by livings124

mloiterman: can you check this on the latest nightlies?

comment:6 Changed 14 years ago by livings124

mloiterman: ping

comment:7 Changed 14 years ago by charles

mloiterman: ping

comment:8 Changed 14 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

No one else has reported on this. Reopen if it's still an issue.

comment:9 follow-up: Changed 14 years ago by sirilyan

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I can verify this happens with build 3811, Mac OS X 10.4.11. If you try to add a new torrent to an already-running Transmission, and the torrent would download to a Samba share (in my case, a WinXP Home box), it will hang and require a force quit, which takes several minutes. It's trivial to reproduce for me.

comment:10 in reply to: ↑ 9 Changed 14 years ago by tiennou

Replying to sirilyan:

It's trivial to reproduce for me.

Then I want to know if you could Shark it while stuck to make sure it really hanged (and it's not just copying files without a GUI telling you it is...). I'm pretty sure letting it running a little while it beachball will un-hang it after the copy is completed.

comment:11 Changed 14 years ago by livings124

sirilyan: do you still see this in 1.00?

comment:12 Changed 14 years ago by sirilyan

I've just downloaded r4635, and the first thing that happened when I started it was this bug manifesting, so it's stilll going on. I'll try to get a Shark report for you tomorrow.

For what it's worth, I've reported this issue to Apple and the bug was closed with a note that it's fixed in Leopard, so it may be something in Tiger's SMB stack that's screwed up.

comment:13 Changed 14 years ago by sirilyan

Correction: a little more experimentation shows it's gotten worse between r3811 and r4635. It's gone from beachballing once at the beginning of the download to beachballing what looks like every time it tries to open a new file for writing on the smb share. Trying to look at the folder in Finder at the same time hangs Finder for as long as it takes Transmission to finish a force quit.

comment:14 Changed 14 years ago by sirilyan

r4794 has mostly fixed the problem. The beachball shows up on opening a file, but it only lasts for about a second and then things resume.

comment:15 Changed 14 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

A little delay seems reasonable. For now I'll close this.

Note: See TracTickets for help on using tickets.