Opened 12 years ago

Closed 12 years ago

#2861 closed Enhancement (duplicate)

Improve UI responsiveness when using "Move Data File To…"

Reported by: dethbunny Owned by: dethbunny
Priority: Low Milestone: None Set
Component: Mac Client Version: 1.83
Severity: Minor Keywords: mac interface
Cc:

Description

When using the "Move Data File To…" command, the UI appears to hang for the duration of the transfer. This should be improved. By doing so, the user has a better idea what's really going on.

My suggestion would be to spin off a thread that handles the copy. If the copy takes longer than a trivial amount of time (say, 1-2 seconds) a dialog box is presented that includes the move progress.

Change History (6)

comment:1 Changed 12 years ago by dethbunny

  • Status changed from new to assigned

comment:2 Changed 12 years ago by livings124

When you assign this to yourself, are you saying you will be submitting a patch?

comment:3 Changed 12 years ago by dethbunny

That's the plan. If you've got feedback about implementation, I'd love to hear it, but this seems like a relatively straightforward patch.

comment:4 follow-up: Changed 12 years ago by charles

dethbunny: cool, thanks for volunteering to add code. (And if you'd like to work on libtransmission too... ;)

This sounds a lot like the patch tiennou mentioned working on three days ago @ http://trac.transmissionbt.com/ticket/1753#comment:20 . You might want to take a look at that and maybe see if his patch is good, or a good starting place, or if I'm confusing two unrelated features.

comment:5 in reply to: ↑ 4 Changed 12 years ago by dethbunny

It does indeed sound like the work tiennou has done. I'll compile from his tree and test it out to see how things work. A "better" fix may require more rework on libtransmission and more complete interplay between it and the GUI.

A certain part of me wants to say "wait until we can just require Snow Leopard, then GCD will make things so much easier." I'm sure that's still a couple of years away, though. Now pondering applications of NSOperationQueue.

comment:6 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from assigned to closed

GCD would be nice, but remember libT is meant to run on multiple operating systems (linux and ideally even windows). I'm going to close this as a duplicate of #1753 and ask you to update there, assuming this is the same basic enhancement. Please reopen if I am misinterpreting this, however.

Note: See TracTickets for help on using tickets.