Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2866 closed Bug (invalid)

Transmission login box will not appear in Google Chrome

Reported by: sakos Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.80
Severity: Normal Keywords: needinfo chrome login
Cc:

Description

I am unable to connect to the Transmission web interface when using Google Chrome after rpc authentication was switched on. Chrome tries to open the web page, but login box does not appear and timeout happens. Reloading the page does not resolve the issue. I have tested the web interface with Firefox 3.5.6 and it works fine, login box appears immediately.

I'm not sure if this is transmission or Google Chrome fault.

Attachments (1)

tr_chrome.pcap (1.6 KB) - added by sakos 12 years ago.
Network capture of web page opening

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by sakos

Network capture of web page opening

comment:1 Changed 12 years ago by charles

  • Keywords needinfo added

I'm not seeing this bug. This is working fine for me with Transmission 1.83 and Chrome 4.0.249.43 (Official Build 34537).

What version of Chrome are you using? Do you have any other details on how to make this issue appear?

comment:2 Changed 12 years ago by charles

another tester in 5.0.319.0 (38290) Ubuntu reports the password prompt works there, too.

comment:3 Changed 12 years ago by charles

another tester on OS X 10.5.8 reports the password prompt works correctly in Chrome 4.0.249.49

comment:4 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Curiouser and curiouser. One of the #transmission irc users was able to consistently reproduce this and even made a video of it @ <http://roly.homelinux.com:10000/b/t/chromebug.m4v>

By following the steps in the video -- typing in the web ui's address in the URL addressbar, entering in the user/pass, hitting back, retyping the web ui's address to load the page a second time, exiting chrome, reloading chrome, and typing the web ui's address a third time -- three testers were able to trigger the same bug.

However, even following these steps, everything worked fine in Firefox 3.5.6 and in the Firefox pre-3.7 nightly builds.

This is looking more like a Chrome bug. Given that it's reproducible and there's a video available, I think you should report this bug upstairs to the Chrome team.

---

Closing this bug as "invalid" because our trac doesn't have a "nottransmission" option.

comment:5 Changed 12 years ago by geirha

I can confirm this (against T 1.83). In Google Chrome (4.0.249.43) I get the same issues explained in the previous post by charles; first time works fine, restarting chrome, I get the error message. Deleting the log (Ctrl+H) for that day, however, makes it work again.

comment:6 Changed 12 years ago by sakos

I have reported to Chrome team. No response yet.

Note: See TracTickets for help on using tickets.