Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2868 closed Enhancement (invalid)

Access to more torrent properties while adding a new one. More straightforward resource management.

Reported by: kovalev Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 1.83
Severity: Normal Keywords:
Cc: Mac client

Description

As customers started to ask for an access to more torrent properties in "Add a torrent" window (http://trac.transmissionbt.com/ticket/2846), I would like to share my view on the following possible enhancements.

  1. It seems natural to invoke all Torrent Inspector ("Properties" in GTK/Qt) instead of a separate "torrent option" dialogue while adding a new torrent. "Set location" (for download) and "Verify local data" options could then be merged to "Files" or "Options" tabs or even moved to a new tab. In the opposite, "Start when added" and "Move .torrent to trash" would fit to "Open a torrent" window along with "Show option dialogue" ("Show torrent properties").
  1. Resource management in "Options" tab of Torrent Inspector could be made more straightforward and easy to customers. First of all, all resources - bandwidth, number of connections and even seed ratio could be handled the same way. "Honour global limits" option seems is not necessary at all. This is by default. Customers however should be able to override automatic resource assignment by setting "Speed limit", "Seed ratio" and "Maximum peers" checkboxes and assigning the values explicitly via "Options" tab. Even a global limit to "Maximum peers-per-torrent" ("Preferences"-"Network") might not be necessary. Instead, an available amount of each resource (both bandwidths and number of connections) could be calculated from a limit set to its total (via global "Preferences") and current total torrents activity. This should be given to customers as a maximum available value upon overriding an automatic assignment. Thus, customers should be aware of current limits and not be allowed to exceed them.

Maybe, global limits to total available resources (bandwidths, connection numbers, even seed ratio?) in global "Preferences" could be handled more gracefully too - via only one tab.

Change History (8)

comment:1 in reply to: ↑ description ; follow-ups: Changed 12 years ago by charles

Replying to kovalev:

  1. It seems natural to invoke all Torrent Inspector ("Properties" in GTK/Qt) instead of a separate "torrent option" dialogue while adding a new torrent. "Set location" (for download) and "Verify local data" options could then be merged to "Files" or "Options" tabs or even moved to a new tab. In the opposite, "Start when added" and "Move .torrent to trash" would fit to "Open a torrent" window along with "Show option dialogue" ("Show torrent properties").

This would split the file selection / file priority selection into a separate tab though, which would make adding a torrent even more complicated than it is now.

As for 2., I'm not sure I understand what you're saying. Would it be possible for you to draw the interface you have in mind?

comment:2 in reply to: ↑ 1 Changed 12 years ago by kovalev

Replying to charles:

Replying to kovalev:

This would split the file selection / file priority selection into a separate tab though, which would make adding a torrent even more complicated than it is now.

Indeed, while "Torrent priority" fits naturally to "Options" tag, "Set location" for download and file selection should belong to "Files" tag. Thus a customer would need to make one more click to switch between the two tags if he(she) wants to modify both. But, on the other side, why don't we have an option to look at (and modify) other torrent properties as well at the very adding? As of my experience, this is necessary anyway in most cases. I totally agree however - this is solely my personal view. Any feedback from customers and developers would be appreciated.

As for 2., I'm not sure I understand what you're saying. Would it be possible for you to draw the interface you have in mind?

Well, in my view: "Honor global limits" as well as "Use global settings" in Torrent Inspector - "Options" tag could be removed at all. Options "Limit download/upload speed", "Maximum peers" and "Seed ratio" should have checkboxes(radio buttons) - the same way as we've got it in a current release. Disabling it would then mean "Use default/global limits". By enabling it, a customer would override a automatic assignment from global limit and set their own local limit applicable to a given torrent only - exactly as we've got it in current release. At this moment however Transmission client should check for a maximum available amount of a given resource and set it as a maximum available value. Customers should not be able to exceed this value while setting their own local limits. Example: let's have "Maximum peers overall" of 200. Let's have two active torrents, with "maximum peers" for one set as 20 and "disabled" (read - default) for another. Then, "maximum peers" assigned automatically to the last one would be 180. If we would add one new torrent and disable its "maximum peers" disabled in a newly added third torrent, then Transmission would share these 180 connections between the two torrents with "maximum peers" disabled (may be honouring torrent priorities). By enabling "maximum peers" for a newly added torrent we would assign our own value to it, but in a given case Transmission should limit its value to 200-20=180 (maybe 179?). The similar method should be used also to set both bandwidth limits - simply by enabling "Limit upload(download) speed", as well as for "Seed ratio". In the last case we don't need to check for available resource. While enabling a local limit option in Torrent Inspector - "Options", Transmision could offer customer a default value from global settings ("Preferences" - "Torrents", "Speed", Network" etc). But in my view this is also an excessive parameter. Instead, Transmission could calculate a default value from maximum available amount of resource as I have tried to describe above. Then, "Maximum peers per torrent" could be removed from "Preferences" - "Network" at all.

  1. In global "Edit"-"Preferences":

Instead of having to set global limits in "Torrents", "Speed" and "Network" tags one could merge all resource limits to one tag "Resources", where "Total upload/download speed", "Default seed ratio" and "Total maximum peers" could be specified.

Once again - this is only my personal view, and I appreciate all feedback from the customers and the development team.

comment:3 in reply to: ↑ 1 Changed 12 years ago by kovalev

Replying to charles:

Replying to kovalev:

Yet one more penny to my explanation.

  1. This would split the file selection / file priority selection into a separate tab though, which would make adding a torrent even more complicated than it is now.
  1. "Torrent priority" would be put to "Add a torrent" window instead of its current place in "Torrent options". Some number of simple and most used option would be added there as well. The default set of these options would be accessible via global "Preferences"-"Torrents" tag. Then, with "Show Torrent properties" instead of "Show options dialogue" set, a Torrent Inspector (Properties in GTK/Qt) would be invoked with "Files" tab active. There a customer would select files of interest and set download location or verify local data that are already there with newly added options from current "Torrent options". Thus adding new torrents could become even faster than now.

As for 2., I'm not sure I understand what you're saying. Would it be possible for you to draw the interface you have in mind?

  1. While setting local limits on speed, peer number and seed ratio via Torrent Inspector, one could only check that local limit is below global limit - this should be enough. The way I have described above is to calculate actual amount of resource (peer number was an example) available to torrent. Obviously Transmission is being doing similar trick while distributing available bandwidth among active torrents. Anyway, "Honour global limits" in Torrent Inspector seems is an excessive option. From there, a customers should just be able to cap speed (peer number, seed ratio) available to a given torrent even below its global limit, simply by enabling related field and putting a new value to it.

I also would like to point out that current release (T 1.83) seems doesn't honour global limit to "maximum peers per torrent". One can have a "maximum peers" in "Properties"-"Options" above global "Maximum peers per torrent" in "Preferences"-"Network". And a number of connections for this torrent will follow its local "wrong" value. Btw, I still cannot see any point to have a global limit to "maximum peers per torrent". We haven't got such a limit for up/down speed, and we have already got "Maximum peers overall". Wouldn't it be better to allow Transmission or a customer to distribute peers the similar way to bandwidth?

comment:4 Changed 12 years ago by kovalev

Ok, this is to summarise my view on interface modification (sorry - I cannot draw interface the way software developers do and then attach a picture or a code):

  1. "Add a torrent" window:
  • put here "Start when added", "Move .torrent file to trash" and "Torrent priority" instead of "Torrent options" window along with current "Show torrent options dialogue";
  • with current "Show torrent options dialogue" set, invoke modified Torrent Inspector (Properties) instead of current "Torrent options", with modified "Files" tab active.
  1. Torrent Inspector (Preferences) - "Options" tab:
  • remove excessive "Honor global limits" for speed;
  • allow "Maximum peers" parameter to be enabled/disabled via a checkbox;
  • with "Maximum peers" enabled, put additional limit to a number of peers in a given torrent the same way as we do it for speed;
  • put a range check in place for customer's set limits to speed and number of peers. There is no use to exceed values set in global "Preferences".
  1. Torrent Inspector (Preferences) - "Files" tab:
  • add "Verify local data" button from Main Menu - "Torrent"/right-click menu. This is to perform verification procedure;
  • put here modified "Set Location" dialogue from Main menu - "Torrent"/right-click menu. Use default destination folder specified in global "Preferences"-"Torrents" when a new torrent is being added. Then look for local torrent data and use if available. When a torrent has already had some local data, allow customer to chose either to move these data to a new folder or to purge old data and use data from a new destination;
  • when invoked from "Add a torrent" window, allow Torrent Inspector either to proceed with a new torrent or to return back to parent window and select a new .torrent file. This is instead of current "Torrent options" window.
  1. Main menu - "Torrent"/right-clik menu:
  • use "Set location" dialogue and procedure from Torrent Inspector - Files.
  1. Global "Preferences"-"Network":
  • remove excessive "Maximum peers per torrent" parameter - use current "Maximum peers overall" instead.

Distribute peers among active torrents the similar way as speed.

comment:5 Changed 12 years ago by kovalev

Sorry - a piece to summary of interface modification

  1. Add to global "Preferences"-"Network"
  • allow "Maximum peers overall" to be enabled/disabled via a checkbox. Thus, allow Transmission to cap global connections the similar way as speed.
  1. Add to Torrent Inspector (Preferences) - "Options" tab:
  • remove excessive "Seed torrent indefinitely" and "Seed regerdless of ratio"; replace "Seed torrent until" radio button with a checkbox. Thus, allow torrent "Seed ratio" to be set the same way as peer number and speed. Use global "Seed ratio" ("Preferences"-"Torrents") enabled/disabled to set default seed limit or allow torrents to be seed indefinitely.

comment:6 Changed 12 years ago by charles

  • Version changed from 1.83+ to 1.83

"Add a torrent" window: - put here "Start when added", "Move .torrent file to trash" and "Torrent priority" instead of "Torrent options" window

If we do this, then people adding torrents by some method other than by selecting a file (such as when a web browser passes the filename along to Transmission) won't be able to "torrent prority" or "start when added".

invoke modified Torrent Inspector (Properties) instead of current "Torrent options", with modified "Files" tab active.

How does this make adding a torrent simpler and easier?

remove excessive "Honor global limits" for speed remove excessive "Seed torrent indefinitely"

These features have their uses and are not going away...

allow "Maximum peers" parameter to be enabled/disabled via a checkbox; - with "Maximum peers" enabled, put additional limit to a number of peers in a given torrent the same way as we do it for speed; - put a range check in place for customer's set limits to speed and number of peers. There is no use to exceed values set in global "Preferences".

Most users don't care about these things when adding a torrent. I think this makes adding a torrent more complicated and confusing. Not even Deluge and KTorrent -- which, by design , present more choices to the user -- throw all this in users' faces when adding torrents.

"Files" tab: - add "Verify local data" button from Main Menu

Actually the "Verify" button's been removed from the "Torrent Options" dialog... verification now takes place automatically whenever the Destination folder is changed.

put here modified "Set Location" dialogue from Main menu

Why?

Then look for local torrent data and use if available. When a torrent has already had some local data, allow customer to chose either to move these data to a new folder or to purge old data and use data from a new destination; - when invoked from "Add a torrent" window, allow Torrent Inspector either to proceed with a new torrent or to return back to parent window and select a new .torrent file. This is instead of current "Torrent options" window.

This is very confusing to me. I don't think I'm understanding you correctly.

  1. Global "Preferences"-"Network": - remove excessive "Maximum peers per torrent" parameter - use current "Maximum peers overall" instead. Distribute peers among active torrents the similar way as speed.

comment:7 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

comment:8 Changed 12 years ago by kovalev

Ok, let's stop unnecessary discussion here. Any major interface refurbishment definitely requires more feedback from customers. Though I am still puzzled with two things:

  1. how "Honor global limits" and "Limit download(upload) speed" work when they are enabled simultaneously via Torrent Inspector - "Options";
  1. how "Maximum peers" set via Torrent Inspector - "Options" deals with "Maximum peers per torrent" and "Maximum peers overall" set via global "Preferences"-"Network". None of these options can be enabled/disabled in opposite to speed.
Note: See TracTickets for help on using tickets.