Opened 12 years ago

Closed 12 years ago

#2871 closed Bug (invalid)

Blocklist sheet does not disappear if closed when app is hidden

Reported by: livings124 Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.76
Severity: Minor Keywords:
Cc:

Description

As reported in #2823. If the app is hidden and the blocklist download finishes installing, the sheet remains shown and cannot be closed.

Change History (1)

comment:1 Changed 12 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

This is an Apple bug, as confirmed by http://www.cocoabuilder.com/archive/cocoa/56801-orderout-sheet-while-app-is-hidden.html?q=close+sheet+hide#5680. I have reported it upstream to them. I could put in a very ugly hack to get around it, but since it is so obscure that doesn't seem worth it. Feel free to reopen if this is particularly bugging you.

Note: See TracTickets for help on using tickets.