Opened 12 years ago

Closed 12 years ago

#2885 closed Bug (fixed)

"Move data file" does not change the location for data yet to be downloaded

Reported by: Tantali Owned by: charles
Priority: Normal Milestone: 1.92
Component: libtransmission Version: 1.83
Severity: Normal Keywords:
Cc:

Description

When using the "Move data file" on a newly added torrent to set the download directory, the torrent is still downloaded to the directory set for incomplete transfers.

It seems more logical to me that you could use the "Move data file" to choose a different download-location even for new torrents.

e.g.: with the current implementation, when the drive with the 'incomplete transfers'-folder is nearly full, you can't download large files even though you have enough space on other drives

Change History (8)

comment:1 Changed 12 years ago by charles

Tantali: I don't think I understand this ticket right. Could describe in more detail what you're asking for in this ticket? :)

comment:2 Changed 12 years ago by Tantali

Well, when you have a directory set for incomplete files, all new files will be created in this directory. When you use the 'Move data file' it will move all files which are already created (including incomplete ones), but new incomplete files will still appear in the folder for incomplete files.

I think it would be handy if the 'move data file' overrides the incomplete files download location (or a similar solution). The reason being that if there isn't enough space left on the drive with the incomplete folder, you simply can't download the file even if you have other drives with plenty of space.

With the current implementation you either need enough remaining space so you can use 'move data file' as soon as the space is allocated or you have to disable the preference for the 'incomplete files'-folder.

With the suggested new implementation, you could use 'move data file' on a torrent to set it's download location (e.g. different drive) and thus moving already allocated incomplete files (which already is the case) AND changing the location where new incomplete files are allocated.

I hope I explained myself better this time. :)

comment:3 Changed 12 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles
  • Priority changed from Low to Normal
  • Severity changed from Minor to Normal
  • Summary changed from "Move data file" should work on new torrents too to "Move data file" does not change the location for data yet to be downloaded
  • Type changed from Enhancement to Bug

Thank you for the description - it cleared up what the issue is completely. I am seeing this behavior as well.

comment:4 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.92

comment:5 Changed 12 years ago by charles

  • Milestone changed from 1.92 to Sometime

comment:6 Changed 12 years ago by charles

I think this would fix it:

Index: torrent.c
===================================================================
--- torrent.c	(revision 10307)
+++ torrent.c	(working copy)
@@ -2544,6 +2544,17 @@
         }
     }
 
+    /* If someone moves a torrent's contents to a directory,
+     * but isn't finished downloading, it's useful to put new
+     * incomplete files there too instead of the incomplete dir.
+     * See http://trac.transmissionbt.com/ticket/2885 for details */
+    if( !err && do_move )
+    {
+        tr_free( tor->incompleteDir );
+        tor->incompleteDir = NULL;
+        tor->currentDir = tor->downloadDir;
+    }
+
     if( data->setme_state )
         *data->setme_state = err ? TR_LOC_ERROR : TR_LOC_DONE;
 

comment:7 Changed 12 years ago by charles

  • Status changed from new to assigned

Fixed in trunk for 1.92 by r10308

comment:8 Changed 12 years ago by charles

  • Milestone changed from Sometime to 1.92
  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.