Opened 12 years ago

Closed 12 years ago

#2892 closed Bug (fixed)

changing port number doesn't actually change until program restart

Reported by: bobjones22 Owned by: charles
Priority: Normal Milestone: 1.90
Component: libtransmission Version: 1.83
Severity: Normal Keywords: port, restart
Cc:

Description

With Transmission 1.83 (10040) for Mac, when I change the "Peer listening port" number in the Network pane of the Preferences window, there is a spinning animation, and it updates to say either "Port is open" or closed (and that works). However, I can tell by watching my firewall logs that the network port of incoming bittorrent connections does not change from the previous setting. Only after restarting Transmission do incoming connections begin to use the new port number.

Change History (4)

comment:1 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 1.90
  • Owner set to charles
  • Status changed from new to assigned

I think r10171 fixes this bug, but I won't be able to test it until tonight. If someone wants to test it out before then, please close the ticket as "fixed" if it works or give details if it doesn't.

comment:2 Changed 12 years ago by charles

Ticket #2825 has been closed as a duplicate of this ticket.

comment:3 Changed 12 years ago by livings124

Assertion failed: (!handle->isMapped), function tr_upnpClose, file /Users/mitchell/Desktop/Transmission/libtransmission/upnp.c, line 66.
Thread 3 Crashed:
0   libSystem.B.dylib                   0x00007fff80badfde __semwait_signal_nocancel + 10
1   libSystem.B.dylib                   0x00007fff80badee0 nanosleep$NOCANCEL + 129
2   libSystem.B.dylib                   0x00007fff80c0a886 usleep$NOCANCEL + 57
3   libSystem.B.dylib                   0x00007fff80c29e3c abort + 93
4   libSystem.B.dylib                   0x00007fff80c16e74 __pthread_markcancel + 0
5   org.m0k.transmission                0x000000010007ae15 tr_upnpClose + 72 (upnp.c:67)
6   org.m0k.transmission                0x000000010008c10b stop_forwarding + 144 (port-forwarding.c:184)
7   org.m0k.transmission                0x000000010008c24a tr_sharedPortChanged + 53 (port-forwarding.c:226)
8   org.m0k.transmission                0x00000001000804cb setPeerPort + 106 (session.c:931)
9   org.m0k.transmission                0x000000010009d434 readFromPipe + 348 (trevent.c:182)
10  org.m0k.transmission                0x00000001000d8d5c event_process_active + 303 (event.c:386)
11  org.m0k.transmission                0x00000001000d90a0 event_base_loop + 377 (event.c:526)
12  org.m0k.transmission                0x00000001000d8f25 event_loop + 35 (event.c:462)
13  org.m0k.transmission                0x00000001000d8d9c event_dispatch + 20 (event.c:400)
14  org.m0k.transmission                0x000000010009d618 libeventThreadFunc + 205 (trevent.c:229)
15  org.m0k.transmission                0x000000010008c56a ThreadFunc + 43 (platform.c:111)
16  libSystem.B.dylib                   0x00007fff80b73f8e _pthread_start + 331
17  libSystem.B.dylib                   0x00007fff80b73e41 thread_start + 13

comment:4 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in trunk for 1.90 by r10184

Note: See TracTickets for help on using tickets.