Opened 12 years ago

Closed 12 years ago

#2896 closed Bug (worksforme)

Completed downloads stay in the 'incomplete' directory

Reported by: keithlard Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.83
Severity: Normal Keywords:
Cc:

Description

This is version 1.83 on OS X. I have the option set to keep incomplete files in a separate directory. Until a recent upgrade (around 1.80 or so) Transmission was correctly moving downloads into the main download directory once they finished.

Now that's not happening - the download completes as normal but it stays in the 'incomplete downloads' directory.

I see someone else has reported a similar problem here: http://forum.transmissionbt.com/viewtopic.php?f=4&t=9129&p=42638&hilit=incomplete#p42638

Change History (12)

comment:1 Changed 12 years ago by charles

Thank you for taking the time to report this bug and helping to make Transmission better. Please answer these questions:

  • Is this reproducible?
  • If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

comment:2 Changed 12 years ago by keithlard

To reproduce:

  1. Enable the 'keep incomplete files in' option and set a different directory to your default download directory.
  2. Download a torrent.
  3. When the torrent completes, the data is still in the 'incomplete downloads' directory.

This happens with every torrent I've tried.

comment:3 Changed 12 years ago by livings124

I cannot replicate this. What are the paths of the two locations? Do you change the location in the add window or the "Move Data File To..." menu item?

comment:4 Changed 12 years ago by keithlard

The default download is '/Users/john/TV'. The incomplete directory is '/Users/john/TV/Incomplete Transmission Downloads'. These are both set in Preferences and I don't need to do anything else to reproduce the issue. It happens with all torrents.

comment:5 Changed 12 years ago by livings124

Can you change the two directories in preferences, and then change them back and see what happens for newly-added transfers?

comment:6 Changed 12 years ago by livings124

Additionally, can you check the message log (Command-3) set to debug, and when the move fails see if anything relevant is printed there. Also check Console.app.

comment:7 Changed 12 years ago by keithlard

Having changed the download directories to something else and back again, it now seems to work fine. Possibly the problem only occurred with torrents added while using a previous Transmission version. If I can reproduce the issue again I'll add the details here, but for now, keep up the good work :)

comment:8 Changed 12 years ago by livings124

What version were you using previously? Do you know if you added a new torrent (before you changed the setting and fixed it) would it still have this problem?

comment:9 Changed 12 years ago by charles

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

Possibly the problem only occurred with torrents added while using a previous Transmission version.

(Tentatively reassigning this ticket to the Mac client...)

comment:10 Changed 12 years ago by livings124

keithlard: ping

comment:11 Changed 12 years ago by keithlard

I was on 1.82 previously so perhaps that's why. I haven't had this problem recur with newly added torrents, so go ahead and close this one if no-one else can reproduce it.

comment:12 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

I can't replicate this or track it down in code. Since it seems to be an issue when updating to >= 1.80 and seems to be hitting very very few users, I'm going to close it.

Note: See TracTickets for help on using tickets.