Opened 12 years ago

Closed 12 years ago

#2907 closed Bug (fixed)

Speed Limit mode not retained after relaunch

Reported by: John Clay Owned by: charles
Priority: High Milestone: 1.91
Component: libtransmission Version: 1.90
Severity: Major Keywords:
Cc:

Description

When Speed Limit mode is set, the limit is not kept upon relaunch. The button still indicates that it's active, and toggling makes it work as expected.

Change History (9)

comment:1 Changed 12 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles

session.c's sessionSetImpl() does not seem to look at TR_PREFS_KEY_ALT_SPEED_ENABLED

comment:2 Changed 12 years ago by livings124

  • Milestone None Set deleted

comment:3 Changed 12 years ago by charles

  • Status changed from new to assigned

comment:4 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

looks like this is a post-1.83 regression introduced by a commit for r2584.

Fixed in trunk for 1.90 by r10217

comment:5 Changed 12 years ago by charles

#2584, not r2584 :)

comment:6 Changed 12 years ago by livings124

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 1.83+ to 1.90

I'm seeing this behavior in 1.90. Confirmed http://forum.transmissionbt.com/viewtopic.php?f=4&t=9572

comment:7 Changed 12 years ago by livings124

  • Milestone set to 1.91
  • Priority changed from Normal to High
  • Severity changed from Normal to Major

comment:8 Changed 12 years ago by charles

The forum post:

i've only noticed this in recent versions (1.90 release and 1.83+ nightly are the only ones i'm sure about), but when i start up transmission, the turtle icon is activated (this is as expected/desired, as it was active when transmission was previously shut down), but from the total transfer speeds it's clear that transmission is using the "global bandwidth limit" rather than "speed limit mode" transfer limits. if i toggle the turtle off and then back on, it starts respecting the speed limit mode.

comment:9 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in trunk for 1.91 by r10229

Note: See TracTickets for help on using tickets.