Opened 12 years ago

Closed 12 years ago

#2924 closed Bug (fixed)

1.90 crashes on startup

Reported by: wafwot Owned by: charles
Priority: High Milestone: 1.91
Component: libtransmission Version: 1.90
Severity: Major Keywords:
Cc: john@…

Description

I just updated to the latest version, 1.90 (10223), and it crashes constantly, even with no activity. I've rebooted and it is still unstable. Any suggestions? The previous version was very stable for me.

Attachments (5)

crash log for Transmission (user- wafwot).txt (25.2 KB) - added by wafwot 12 years ago.
crash log
Transmission_2010-02-18-120556_G5.crash (25.1 KB) - added by wafwot 12 years ago.
crash log
Transmission_2010-02-18-183134_T-Bone.crash (30.6 KB) - added by keithlard 12 years ago.
nifoc_transmission1.90.log (34.6 KB) - added by nifoc 12 years ago.
Transmission_2010-02-19-071819_G5.crash (25.1 KB) - added by wafwot 12 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 12 years ago by Robby

Post a crashlog, please.

Changed 12 years ago by wafwot

crash log

Changed 12 years ago by wafwot

crash log

Changed 12 years ago by keithlard

comment:2 Changed 12 years ago by keithlard

  • Cc john@… added

I can reproduce this as well - two crashes today since I updated to 1.90. Crash log attached.

comment:3 Changed 12 years ago by wafwot

  • Resolution set to fixed
  • Status changed from new to closed

I went Applications/Utilities/Disk? Utility and ran 'Repair Disk Permissions'. That seemed to fix the problem.

comment:4 Changed 12 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to reopened

keithlard, same for you?

Changed 12 years ago by nifoc

comment:5 Changed 12 years ago by wafwot

Before running 'Repair Disk Permissions', Transmission would repeatedly crash in less than a minute, even with no torrents running (upload or download). After running 'Repair Disk Permissions' and without doing another reboot, Transmission has been running for hours at full speed with at least 13 torrents running. Problem solved.

comment:6 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 1.91

The telltale sign for this crash is the "Curl_raw_equal" in thread 2 in the crash report. I don't think that the Disk Permissions thing is related to this crash.

comment:7 Changed 12 years ago by charles

  • Summary changed from crashes constantly with latest update to 1.90 crashes on startup

Could you please try a nightly build of r10230 (or higher) from http://build.transmissionbt.com/job/trunk-mac/ and see if the problem persists? If so, could you please attach a new crash log from that nightly build? Thanks!

Changed 12 years ago by wafwot

comment:8 Changed 12 years ago by wafwot

After running successfully almost all night, Transmission started crashing again. I installed r10230, rebooted, ran 'Repair Disk Permissions', and it still crashes after a very short time.

comment:9 Changed 12 years ago by charles

Interesting. It's a similar crash, but not the same crash.

Could you please do this for me:

  1. Please uninstall the nightly r10230 build and revert to Transmission 1.90 for this test. The reason for this is to make it crash quickly instead of running all day. ;)
  1. Launch Transmission 1.90 from a terminal with this command. (This should all be on one line, so ingore the line wrap that trac adds): TR_CURL_VERBOSE=1 /Applications/Transmission.app/Contents/MacOSX/Transmission 2>/tmp/runlog
  1. After Transmission 1.90 crashes, mail me the /tmp/runlog file. It will have confidential information in it about which torrents you're using, so don't attach it to this ticket. My email is charles transmissionbt.com

comment:10 Changed 12 years ago by charles

  • Owner set to charles
  • Status changed from reopened to new

comment:11 Changed 12 years ago by charles

  • Status changed from new to assigned

comment:12 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

This has been reported as fixed by four testers in a row in the forums. Marking this as closed.

http://forum.transmissionbt.com/viewtopic.php?p=45078#p45078

Note: See TracTickets for help on using tickets.