Opened 11 years ago

Closed 11 years ago

#2927 closed Enhancement (fixed)

transmission-remote: No way to add a new torrent with a custom download directory without clobbering the incomplete dir setting

Reported by: mechanic Owned by: charles
Priority: Normal Milestone: 2.00
Component: Daemon Version: 1.90
Severity: Normal Keywords:
Cc:

Description

When calling transmission-remote -t $TORRENT --move it moves the data location immediately, instead of respecting the --incomplete-dir setting. Instead of changing the behavior of --move, I think a new option for per-torrent completed-dir should be added. --download-dir is global and trying to write scripts with that can lead to race conditions (change --download-dir, add new torrent, change --download-dir back to default dir).

Change History (7)

comment:1 Changed 11 years ago by leena

  • Type changed from Enhancement to Bug

+1

comment:2 Changed 11 years ago by charles

  • Component changed from CLI to Daemon

comment:3 Changed 11 years ago by charles

  • Keywords needinfo added
  • Type changed from Bug to Enhancement

leena: Moving the incomplete data immediately when "torrent-set-location" is called is a feature, not a bug. See ticket #2885 for more information on that decision.

Mechanic: possibly tr_torrentSetDownloadDir() could be exposed via RPC, but I'm undecided on whether or not it's a good idea. For one thing, its use in the GTK+ and Mac clients is already pretty kludgy -- I'm more inclined to remove it than to formalize it further. What is the use case that you have in mind for this?

comment:4 Changed 11 years ago by charles

Ah, okay. After rereading the ticket, I think I have a better understanding of this. My previous comment was reading way too much into this request wrt its effects on libtransmission and RPC.

From the use case described in the Description, it looks like the problem is there's no way to set both the incomplete-dir and download-dir of a torrent being added in transmission-remote.

comment:5 follow-up: Changed 11 years ago by livings124

All clients allow setting a global incomplete directory, but not per-torrent. Does the daemon allow that?

comment:6 in reply to: ↑ 5 Changed 11 years ago by charles

  • Keywords needinfo removed
  • Milestone changed from None Set to 2.00
  • Owner set to charles
  • Status changed from new to assigned
  • Summary changed from transmission-remote: --move doesn't respect --incomplete-dir to transmission-remote: No way to add a new torrent with a custom download directory without clobbering the incomplete dir setting

Replying to livings124:

All clients allow setting a global incomplete directory, but not per-torrent. Does the daemon allow that?

No.

comment:7 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Added to trunk for 2.00 by r10543

Note: See TracTickets for help on using tickets.