Opened 11 years ago

Closed 11 years ago

#2956 closed Bug (invalid)

Very slow working RPC in transmission-daemon

Reported by: urandom Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.91
Severity: Normal Keywords:
Cc: smirnoffjr@…

Description

After some time transmission-daemon, which even not downloading and not seeding starting responding very slow. Loading web-ui also as some action with file in torrent (e.g. changing priority) taking ~10-15 sec. Local transmission-remote taking ~5 sec just to list torrents. In attach strace of transmission remote for looking where it stuck. Don't know what useful info I can provide...

Attachments (1)

strace_output (36.8 KB) - added by urandom 11 years ago.
transmission-remote stucking between lines 433 and 450

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by urandom

transmission-remote stucking between lines 433 and 450

comment:1 Changed 11 years ago by urandom

  • Cc smirnoffjr@… added

Uh-oh. This behavior was detected on Ubuntu Server 9.10 x86_64 in transmission-daemon 1.8x and 1.9x, version 1.7x working excellent.

comment:2 Changed 11 years ago by livings124

#2904 appears to be a duplicate of this.

comment:3 Changed 11 years ago by wereHamster

The issue reported by me as #2904 seems to have been caused by libevent's default backend on OpenSolaris (event ports). After I configured libevent to use poll, the issue completely disappeared. I have to set both EVENT_NOEVPORT=1 and EVENT_NODEVPOLL=1 - devpoll, the second backend in priority on OpenSolaris, doesn't work either.

comment:4 Changed 11 years ago by livings124

Is this be closed and reported upstream, or should something to be done on our end?

comment:5 Changed 11 years ago by wereHamster

I guess that should be reported upstream. I don't think T can nor should do anything about it, it's essentially a libevent issue, though I'm not sure if it is specific to how T uses libevent or if other applications suffer from it.

comment:6 Changed 11 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Closing, as this appears to not be a Transmission issue.

Note: See TracTickets for help on using tickets.