Opened 12 years ago

Closed 11 years ago

#2978 closed Enhancement (duplicate)

Filter torrents that are actively transmitting data

Reported by: lukasv Owned by: kjg
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.91
Severity: Normal Keywords:
Cc:

Description

Hello,

I would find it highly useful to be able to filter the web client to show only active torrents.

And by active I mean like,

((download_speed > 0) or (upload_speed > 0))

Just like you can in the GTK client. This is really neat if you have a lot of torrents and want to know which ones are transmitting.

I think a lot of users would appreciate this.

Cheers!

Lukas

Change History (7)

comment:1 follow-up: Changed 12 years ago by charles

  • Component changed from Web Client to Transmission

I'm not sure whether or not I like this idea, but I do know it doesn't make sense to have it in one of the GUIs but not the other, so I'm reassigning this request from "Web Client" to "Transmission".

comment:2 Changed 12 years ago by livings124

The Mac client does have an "active" filter.

comment:3 in reply to: ↑ 1 Changed 12 years ago by lukasv

Replying to charles:

I'm not sure whether or not I like this idea, but I do know it doesn't make sense to have it in one of the GUIs but not the other, so I'm reassigning this request from "Web Client" to "Transmission".

Unless I'm mistaken, all the GUIs (GTK, QT, Mac) have this feature, it's only the web client that is lacking it.

comment:4 Changed 12 years ago by charles

The Qt and GTK+ clients will flag torrents as "active" if Transmission and a peer have agreed to share data (in BitTorrent? protocol terms, the interested + unchoke messages have been processed). This means it's possible for some torrents whose speed is currently zero to show up in the active filter.

I don't think this is the same behavior followed by the Mac client...?

comment:5 Changed 12 years ago by livings124

The Mac client marks a file active for the filter if it is not paused and not stalled (as defined in prefs).

comment:6 Changed 12 years ago by livings124

  • Component changed from Transmission to Web Client

comment:7 Changed 11 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #3281. Closing this one, since the other ticket has a patch.

Note: See TracTickets for help on using tickets.