Opened 12 years ago

Closed 12 years ago

#3011 closed Bug (fixed)

"Edit Trackers" dialog not reset after Cancel

Reported by: lubomir.marinov Owned by: charles
Priority: Normal Milestone: 1.92
Component: GTK+ Client Version: 1.91
Severity: Normal Keywords:
Cc:

Description

Steps to reproduce:

  1. Open the Properties for a torrent with multiple trackers, navigate to the Trackers tab and click the "Edit Trackers" button.
  2. Delete a few of the trackers. In my case, I deleted the second, the third and the fourth.
  3. Click the Cancel button of the "Edit Trackers" dialog.
  4. Click the "Edit Trackers" button of the Properties dialog.
  5. Examine the trackers in the "Edit Trackers" dialog.

What happens: The trackers in the "Edit Trackers" dialog are as they were left at the end of step 2, just before step 3/clicking the Cancel button. In other words, though the trackers in the Trackers tab of the Properties dialog are not modified, the trackers in the "Edit Trackers" dialog are modified.

What is expected to happen: Because step 3 cancels the modifications applied in step 2, the "Edit Trackers" dialog should afterwords display the unmodified list.

Other information: I'm running Transmission 1.91 (10268) from the Launchpad PPA on 64-bit Ubuntu 9.10.

Change History (3)

comment:1 Changed 12 years ago by livings124

  • Component changed from Transmission to GTK+ Client
  • Owner set to charles

comment:2 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.92
  • Status changed from new to assigned

comment:3 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in 1.9x by r10350 for 1.92

Fixed in trunk by r10351 for 2.00

Note: See TracTickets for help on using tickets.